Tumult Hype Animations Wordpress Plugin

wordpress

#83

You may be able to use the shortcode in the method that he described (do_shortcode), but it would be a lot easier to just upload your document and then click ‘copy code’ in the line item for the uploaded document to get your embed code. In your post here, you don’t have the full URL of the Hype document included so it is likely not displaying.


#84

That’s odd – can you share more info about the error in a private message? If you can share login info I can see what might be going wrong here. The plugin places uploads in wp-content/uploads/hypeanimations/# Where # is the ID of the upload which will automatically increment. So one thing I would check on your end is that you haven’t adjust the ‘content URL’ value: https://developer.wordpress.org/reference/functions/content_url/.


#85

4 posts were split to a new topic: Perform an Action when Visible


(Jose) #86

Hello,

When I try to activate the plugin in my WP DIVI site I get the error:

Fatal error: Can’t use function return value in write context in /var/www/vhosts/sempi1.metalesdeinversion.com/httpdocs/testwp/wp-content/plugins/tumult-hype-animations/includes/adminpanel.php on line 404

I’ve checked permissions and all are in rwx rwx rwx.

Thanks in advance.


#87

Was this downloaded from the official plugin repository? Do you have PHP 5.4 or later?


(Jose) #90

Our PHP version was not 5.4.


(Jose) #91

Now I have a problem displaying an oam with flexible design (sorry, I don’t know the exact words, my hype is in spanish). If I use a file without resizing objets it works fine in my WP, but if the objects has some resizing it is not displayed.

If I test the exported html in my browser it works fine.

Thanks in advance.


#92

I don’t recommend using responsive settings for the height dimension unless you have a good understanding of your Wordpress theme. Are you using scale properties on both width & height?

There’s many threads here regarding flexible layouts and embedding in Wordpress (though there are not any in Spanish). The quick fix is to disable the ‘height’ scale checkbox. A bit more info here:

Here’s how to determine how a responsive document (on the width dimension) will behave in your Wordpress theme: https://www.youtube.com/watch?v=CuwkJTtuGLc. That video was created prior to the Wordpress plugin, but the same rules apply. (The part that no longer applies is the part regarding FTP uploads, since the plugin handles that).


(Jose) #93

It worked disabling height.

Thanks!!


(Jose) #94

One more thing… Is there any way to make the animation start only when it is visible?

Thanks.


#95

Yup, here’s info on that: https://tumult.com/hype/documentation/3.0/#viewport-actions – Make sure you embed the animation using the ‘div’ method (the default) not the ‘iframe’ method.


(Jose) #96

Once again: Thanks!! It worked.

Every time I suggest anybody to start using Hype I say it is not only Hype, it is Hype and the best support ever.