Tumult Hype Animations Wordpress Plugin

wordpress

#41

Uncheck scaling on the height dimension?


(Gordee McBride) #42

Yeah I had already done that I am now thinking its an issue with permissions in wordpress as when I switch to iframe I get this
Forbidden

You don’t have permission to access /wp-content/uploads/hypeanimations/1/index.html on this server.
I have created a test page with a simple animation to test with
also here is the simple animation


boxTest.hype.zip (10.2 KB)


#43

You may need to manually set the permissions of the hype animations folder to be 755 in your FTP folder. That URL doesn’t seem to be working: http://www.idlanguages.com/wp-content/uploads/hypeanimations/1/index.html

This might be caused by an htaccess setting in the root of your site or in wp-content which restricts the loading of .html files, but getting access to your site would be helpful so I can dig in a little bit. (You can send me a pm if you’d like me to check it out)


#44

4 posts were split to a new topic: Setting a minimum height for an embed using the Hype Animations Plugin


#47

I didn’t see this until tonight. So, I tested it.

My security settings are pretty strict. Here’s the error it throws…

EvalError: Refused to evaluate a string as JavaScript because 'unsafe-eval' is not an allowed source of script in the following Content Security Policy directive: "default-src 'self' 'unsafe-inline' data: https://photics.com".

That’s with the “div” method. Here’s what happens with iFrame…

I suppose I could use the “class” field to specify a height. I was about to go to sleep just before I read your message, so maybe I’ll look more at this tomorrow. For now, I just reverted back to plain HTML / iFrame.

…but wow, the single OAM file seems like a good thing to use. It dramatically reduced the size of the project… from about 500KB to about 400KB.


Update: Using the “iFrame” mode, and a CSS Class to specify the height, worked. It looks like it just expands the files into the “hypeanimations” directory, so no space savings. That would have been cool. This should be much easier for people though, as FTP isn’t needed. Looks like a good plugin.


(Gordee McBride) #48

Hi Daniel back again. I am adding the plugin to a different website from last time. every time I try to activate it I get the following

Fatal error: Can’t use function return value in write context in /var/www/vhosts/52/695582/webspace/siteapps/WordPress-109132/htdocs/wp-content/plugins/tumult-hype-animations/includes/adminpanel.php on line 382

Any idea whats causing that?


#49

Haven’t seen that error before. Did that website previously have the plugin installed (an older Beta version maybe?) That line is pretty innocuous and haven’t seen it trigger an error before.


(Gordee McBride) #50

No it was a fresh install. I have put the plugin on a few sites now with minimal issues but this one has me stumped. the site was a one click wordpress from black knight I have even tried on another, set up the same way, with no problem.
My thinking at the moment is to strip back the plugins and see if there is a conflict. Other wise I am thinking a manual wordpress install but it means me rebuilding the whole site


(Mark Hunte) #51

I wondered if it was a php version issue.

I found this thread which seems maybe the same issue you got here.

If the php version is an older one than 5.5 then the functions using empty will not work as the return value type has changed in later versions.
The answer seems to be implicitly type the type…

Array()

So if you are using empty I think the required php verision will need to be 5.5.

Maybe have a check for version and have a set of functions that work for the older version or maybe changing the type for the return

Full answers here


(Stefano) #52

Hi

I have this problem when i upload a new animation .OAM … nothing is created


#53

3 posts were split to a new topic: Wordpress Plugin Conflict - Hype Animations Plugin and Google Maps Easy


#54

Are you able to share login info with me so I can check this out? (You can private message me by clicking on my avatar)

Can you try replacing functions.php with the contents of this file?


(Quint Rahaman) #55

Hello @Daniel ,

How can an OAM widget be created for custom slices in the Advanced Export?


Wordpress Plugin Conflict - Hype Animations Plugin and Google Maps Easy
#56

Ayo Quint,

It’s built for entire documents – there isn’t a way to do this with slices. Can you share a little bit about what you’re working on (to understand this as a feature request? )


(Quint Rahaman) #57

Hello @Daniel,

I am/have been building a web app and I am using AppPresser to add the necessary “wrapping” around my site to produce an “app” for the Apple App Store and the Google Play Store (in alpha testing presently). I have used Hype to create a document (actually, three copies thus far), where each contains different layout sizes. I could not use a “responsive” design approach (or I couldn’t figure out how to do it), so I created layouts for the most popular mobile device sizes: all iPhones (waiting on Cordova to update for iPhone X), and the most reasonable layout mix for Android (Samsung S5 through S8, for example).

Each exported slice is placed on its appropriate WordPress page. I then use AppPresser along with other code to determine the layout dimensions of the user’s device and thus, the Hype document for that specific page is loaded. In the past, I exported the entire Hype document and my AppPresser app would use that single page. The performance was not good, which either you or Jonathan recommended using slices to selectively load what was required.

Every time I make a change to the Hype document, my workflow after exporting the slices is quite involved, aka a monstrous pia. :wink: That’s why I asked about the OAM Widget by Slice. If that were possible, all I would have to do is to click on update for each OAM Widget and be done with it.

Not for public consumption (just a mechanism to engage in dialogue): https://telesis.wefoster-platform.co/
Scroll down to the demo. That’s your Hype document (my S5/S6/S7 slice, and the resolution is so-so). You can mess around with it if you like.
P.S. None of the videos on the page contain audio.


(Jonathan Deutsch) #58

I filed an item on our feature tracker for this ability! Thanks!


(Alex) #59

Hello @Daniel,

I found debug errors, and here is details just for your reference.

Firstly, I enable debug by custom: define( ‘WP_DEBUG’, true ) in the file of wp-config.php, and update plugin and activate it.

1.I found you changed the folder name of plugin: http://prntscr.com/hzsayf, right?
2. I deleted the older plugin at wordpress admin dashboard, and installed it again, once it was activated the older issue at this top is still there: Tumult Hype Animations Wordpress Plugin

since we sometimes optimize the database by some plugin like:https://wordpress.org/plugins/wp-optimize/ , To be frank, I am a little worried about it effect potential database safety :slight_smile:

3.the debug errors message is at backend please check the screenshot:

The plugin generated 360 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

Please note that

Alex


(mobileme4) #60

Hi-

I tried several times and different ways of using the plugin, but am getting blank spaces.

The OAM is clearly uploading, and I can select it from the Hype Animations button on a new post, but I still get the blank space that looks about the size of the document.

I have unchecked the ‘Scale’ box for both dimensions.

I have exported to a folder and installed through WP using FTP, but the same file as an OAM doesn’t work.

I have tried it in a new post, and in a container in a page, but no luck.

Would you please guide me as to what to check next?

Thanks!


#61

Do you see any errors in your browser console? This will tell you if:

  1. the actual generated JS file being referenced is being loaded
  2. there are any Cross Origin errors ( There is an issue where some sites don’t allow displaying Javascript within their own pages if you have CORS settings set to be super strict. )

Did you try switching the embed style to be Iframe as opposed to the default ‘div’ method? This might tell you if something on your Wordpress site is conflicting with the Hype animation when displayed in the same frame.

Seeing the page would be great if you can share it. Feel free to share with us privately at support@tumult.com.


(mobileme4) #62

Thanks, Daniel-

I played with several setting in the Hype Document, at this point not sure what I changed, but I can now upload an OAM file that I exported, and insert it with a shortcode in a post. I can now see the widget on my post.

One issue remains, though:

The widget is not sensitive to window width or device width. I have tried under the Document panel in the inspector to change the Mobile Options section to Document Width and Device Width. But when I try maneuvering the window in Safari, the widget does not change in size at all. I am hoping this is a simple fix, and I am just missing something simple.

Under the Scene panel, I have the Width at 100%. I have tried inserting the shortcode within a text box in a normal container within my theme, no luck.

Is there an easy way to set this to be responsive, just in overall width? I don’t need the individual elements to change.

Thank you!