Tumult Hype Animations Wordpress Plugin

wordpress

#21

Can you uninstall the plugin, then on your FTP server, can you delete this folder:

/wp-content/uploads/hypeanimations/

… then reinstall again from the latest?

Thanks for your help!


(Ignacio Rosell) #22

Thank you Daniel,

I have proceed as describe, several times, with the latest version.
I have also deleted the folder in the server.

Same error message.

It seems that for some reason, the plugin does not create the folder …/Assets/…
I can see it creates the …/hypeanimation/tmp, but not the Assets.
…/tmp is empty after the error message.

I have tried with different test animations. Same error message.

Thanks again for your support
Cheers
Ignacio


(Alex) #23

Hello,

I just doubt that your wordpress project were made some special high permission or maybe some security plugins, so you might like have a check. If yes, you might change that folder to be low permission so that it allow to write into it, or temporally deactivated some security plugins.

I am running wordpress Multisites, it works fine, 31 is ID of our test site for Hype animation project, and here is the screenshot of Wp-content of Our FTP for your reference, it works fine:

and permission that folder:

I just guess 755 is needed.

Alex


#24

The plugin is now live. I’m still interested in helping folks out with bug reports and resolving issues. Please DM me or create a new post so we can work on any issues that come up.

@Nacho did you get my DM from a couple days ago?


#25

Would be awesome if you could try this out again now that’s it’s live. The site embeds using the protocol of the current page so it should work within your security settings.


(Alex) #26

Hello @Daniel and @Nacho

I am sorry for my oversight.

I found I can not upload . oam file at backend with hype-wordpress-plugin-master( the latest version which you merged.)
But it works at frontend with the oam files that already uploaded before.

and The version of “hype-wordpress-plugin-short-tag” from tokkonopapa works both frontend and backend.

Here is my test process in wordpress Multisites and some improper information at backend when upload oam files:

1#In order to try to avoid any conflict among plugins, I deactivated all plugins network widely. and only leave hype-wordpress-plugin-master activated in a subsite. the shortcode of any uploaded oam file will be [hypeanimation_anim id=“0”]

there will no uploaded file listed at backend, and the frontend page will be empty if put [hypeanimation_anim id=“0”] in a page.

conclusion: it works for the oam files that already uploaded, but it not works with upload any new oam files.

2# if activate Geo-IP-Block network-widely, the shortcode for any uploaded cam file will be [hypeanimation_anim id=“10500”]

That is all.

Alex


(Alex) #27

After test, I think it not work with Wp-content-security-policy.

Alex


#28

Thanks for this report. Can you do a full reset and delete the plug-in? This will delete all previously uploaded documents.

A lot has been redone since tokkonopapa’s merge so it probably will not smoothly upgrade.


(Alex) #29

ok, I will. I tested the above process by uploading and deleteing them only with ftp, should I test to delete and reinstall it at Wordpress dashboard?

If yes, please let me know. Thanks.

Alex


#30

I recommend deactivating then deleting the plug-in from the plug-in page. This will delete the associated database and the hypeanimations folder. Then reinstall from the official plugin repository and let me know what you see.


(Alex) #31

Once click delete,

click ok, error message show up:

Deletion failed: <? if ( !defined( 'WP_UNINSTALL_PLUGIN' ) ) exit(); global $wpdb; $wpdb->query( "DROP TABLE IF EXISTS {$wpdb->prefix}hypeanimations" ); delete_option( 'hypeanimations_db_version' ); function hyperrmdir($dir) { if (is_dir($dir)) { $objects = scandir($dir); foreach ($objects as $object) { if ($object != "." && $object != "..") { if (filetype($dir."/".$object) == "dir") hyperrmdir($dir."/".$object); else unlink($dir."/".$object); } } reset($objects); rmdir($dir); } } $upload_dir = wp_upload_dir(); $anims_dir=$upload_dir['basedir'].'/hypeanimations/'; hyperrmdir($anims_dir); ?>{“success”:true,“data”:{“delete”:“plugin”,“slug”:“tumult-hype-animations”,“plugin”:“hype-wordpress-plugin-short-tag/hypeanimations.php”,“pluginName”:“Tumult Hype Animations”}}

and the interface shopped as the screenshot:

refresh page, that will disappear.

and then I search Hype plugin, it allow to install, so I installed it from wordpress plugin repository:

after activated it in subsite, but I found the animation data has not be deleted, they are still here:

and it support upload:

and I deactivate it in subsite, and go back to delete again, the error will show up again. actually, I retried several times, that error message will appear everytime.

Alex


#32

Hmm this means that the uninstallation (which should delete the DB entries from your database) did not complete, which might cause problems.

Did the item you uploaded (ID 24) work when you place it on a page?


(Alex) #33

YES, it works.

Alex


#34

If you’d like to clean up those DB entries, you can safely remove everything < ID #24. Glad to hear it’s working! Can you test delete and update for ID 24 as well?


(Alex) #35

Yes,example:

before update, it’s name is Aferica~~~


and I will use another file to update, and if it success, the name will change:

1# before upload:


2# after update:

FYR, I do not know why there is different with my test before, I tested before in quite clear environment. the only difference is that I switch plugin with FTP.

Alex


#36

7 posts were split to a new topic: Troubleshooting Responsive document in Wordpress Plugin


(Alex) #37

Hello @Daniel,

Any plan to update plugin?:slight_smile:

Alex


#38

Instead of using the Document Name as the display name, the update of the plugin (from the plugin repository) uses the filename. This was part of a set of required changes to ensure that text displayed by the plugin followed security plugin guidelines. Since you had an old version of the plugin (and you have database entries from before the stable release) your document name was using the old format.


Troubleshooting Responsive document in Wordpress Plugin
(Alex) #39

So, What should I do or just leave it work? thanks.

Alex


(Gordee McBride) #40

Am I doing something stupid?
Ihave tried following the steps in the plugin and it produces blank space. I tried manually embedding and get 4 odd looking boxes/rects.
I assume as neither method works that it’s something to do with my project settings in hype but for the life of me I can’t figure out what