Troubleshooting: Connecting to Hype Reflect

knowledgebase

#1

Hype Reflect is a quick way to preview your Tumult Hype document on an iOS device. If you don’t have it yet, you can download it here: http://bit.ly/HypeReflectApp.

This page shows how it works: http://tumult.com/hype/reflect/

If you are having issues previewing your document on Hype Reflect please follow these steps:

  1. Make sure that your iOS device and your computer are connected to the same WIFI network.
  2. Restart your iOS device & turn WIFI on your Mac off and on and try previewing again.
  3. Open System Preferences on your Mac and open the ‘Security and Privacy’ or ‘Security’ area. In the ‘Firewall’ section, click ‘More Options’ and make sure that ‘Block all incoming connections’ is not checked. (View Screenshot).
  4. Make sure that firewall applications such as Little Snitch do not block connections requested by Tumult Hype. To edit blocked applications, open Little Snitch’s preferences.
  5. Make sure that devices on your local area network can connect to other devices on your network. Your router should not be blocking connections between local devices; you may need to contact your network administrator to resolve this issue if you are connecting to a managed network.
  6. Upgrade to the latest version of iOS that your device supports. If you’re having trouble upgrading, please read this Apple support article.

If this doesn’t resolve the issue please contact us. You can email us directly and attach files here: support@tumult.com

Here’s more information on how the connection process technically works:

More information about Hype Reflect can be found here: http://tumult.com/hype/documentation/reflect/ & http://tumult.com/hype/reflect/


Connecting to Hype Reflect
Hype Reflect doesn't work with Hype 3.5.3
(martijn stellingwerff) #4

Now that you ask, indeed, I have seen this much more than before:
That’s on iOS 8.1 and OSX 10.10.


(Malik) #5

Also getting the same error… will update iOS to 8.1 now… and keep you posted.


#6

Are you seeing this more since being in the Beta program or because of a different upgrade event?


(Malik) #7

only while in beta program


(Malik) #8

it doesnt seem to find the ipad… i renamed the ipad, and it doesnt refresh in Hype 2 or 3 (i have both installed on the same macbook) I just cleared the recent devices… and now nothing is showing up. :frowning:


(Ryan Nielsen) #9

Can you please try turning Wi-Fi off and back on, on both your Mac and iPad?


(Malik) #10

Still no joy with hype reflect, I reset the wifi and even re installed hype reflect on both my iPad and iPhone. It doesn’t see any of the devices. :frowning:


#11

Sorry to hear that, @malik – are you on Yosemite 10.10.1? What kind of router are you using? Do you have any firewall softer (like Little Snitch) that might be blocking a connection?


(René) #12

Ever since iOS8 and Yosemite, we have on all machines a kind of WiFi hell…
I installed a brand new Airport extreme and it’s still not fixed.
Same for other apps that connect with my macbook, like Logic X Remote and Vienna Remote app on iOS.


(Jonathan Deutsch) #13

FYI - OS X 10.10.2 and iOS 8.1.3 were released today and may improve connectivity issues. If you’re still seeing problems, please do let us know!


(martijn stellingwerff) #14

The problems I had with connecting to Hype Reflect are totally solved, it works very well with the new updates. (sorry I did not answer earlier)


(Trey Yancy) #15

I am using 10.8.5 and an iPad 4 running 8.3

I can connect and view the projecton the iPad but exactly one second later Reflect quits. I’ve restarted / relaunched everything. This a consistent behavior.

(Everything works perfectly on my 6 Plus.)


(stephen) #16

After it crashes could you go to Setings->Privacy->Diagnostics & Usage->Diagnostics & Usage Data and see if there is a crash log for Hype Reflect. You should be able to copy/paste the log and send it to me.

If you sync with iTunes you can also find the crash report in ~/Library/Logs/CrashReporter/MobileDevice on your Mac.

Thanks for reporting this.


(Trey Yancy) #17

Here’s the log for my problem getting Reflect to connect to Hype. (Hype 3.0.3, OSX 10.8.5 / iOS 8.3, iPad 3)

ReflectCrashReport.txt.zip (4.5 KB)


(Mark Hunte) #18

I have been getting the connection issue a lot. Making it impossible to use with any degree of reliability.

My Mac is 10.10.3 and the latest Hype and Hype Reflect.


(Mark Hunte) #19

I do seem to be getting better response on 10.10.4 and iOS 8.4 which has reverted back to mdNSResponder

The updates are out today…


(Mark Hunte) #20

As an aside and tip:

I am some times in a location where I will consistently not be able to use Hype Reflect over WIFI Network.
This being due to some setup on the network all by devices are connected to. I have no control over this network.

It just dawned on me That I can just set up a create a new Network from my Mac using the ‘Create Network…’ menu under the WIFI menu bar. Then join it from my devices. Worked like a charm.


(theron_hp) #21

Hi. I was working with Reflect yesterday and it worked fine. It then stopped working. The Reflect page is just white. No information on it. When I select the Safari button, it does load the project in Safari. So I suppose the info is getting to Reflect, but not displaying in Reflect. Any ideas? Its annoying. The problem is on my iPhone and iPad.


#22

Hmm that’s odd – did anything change about your network setup? A quick restart of your devices & modem might be a quick workaround for this if nothing else changed.