(Part 1) Xcode Build Templates for your Apps - To drag and drop your Hype html exports into

Thanks f@Djon.

To Note @Djon was one of my original testers way back when I started these templates.
The external linking if I remember correctly is in regard to how xcode/swift deals with handling web links in the App aand refering back to the app .
We add some code to handle it into his copy of the Templates. ( i.e customising them for his needs )

I may bring that up as an example in part two.


Sounds really cool - I’m interested in your guitar apps! What sort of guitar apps are they?


Have a look here:


Very cool! Thanks for sharing :slight_smile:

1 Like

7 posts were split to a new topic: Xcode + Gyroscope Troubleshooting

Hi Thanks for the Templates.
If i try to add my hyperesources Folder Xcode crashes down.
do you have any idea why?
Thank you very much. XCODE Version 11.3.1 (11C504)

It is probably related to this rather than the template.


Same for me.

Crash when hypersources folder is drop into Xcode.

Catalina 10.15.4
Xcode 11.3.1

I recommend upgrading to the newly released Xcode 11.4 and see if it still happens. Those who have upgraded haven’t reported hitting it.

Oh wow, this is some next level stuff thanks Mark. Wish there was a video tutorial.

Works great in 11.4 !

1 Like

Video Please!!!

Video of what

1 Like

I have already tried with your template and I get an error when I export with file … That is why it told you that I need a video tutorial. Also what xcode version. Thank you

@Casimiro I am not going to do a video.

Especially as I have know idea what the error is you are getting?
Can you please give more detail of exactly what you are doing,

whats producing this error?

i also ran into the error.

In xcode version 12 everything worked.
But yesterday in xcode 13.1 I just got "hello world"
If necessary, I can take screenshots

Yes please. Particular any errors you are getting.

I am still on 12, will update and check out the changes. ( Also not my Mac cannot be upgraded to Monterey, so fingers crossed )


Hmm, I had assumed that the issue was SwiftUI was being forced instead of a Storyboard since I saw a ContentView.swift file in the new projects.

I expected to see the 'Hello world'

But no, it all worked. The contentView file is ignored.
The single view template and postMessage template both worked.

So Xcode 13 on Big Sur. Apart from an extra file the templates work.

So not sure what you are doing. Can you post your screen shots and tell me what you did to set your self up. ???

1 Like

Yes, it seems to me that the project is created in SwiftUI (by default)

I don't know what I did next (I installed the iOS 14 emulator, created a new simple project (new project>ios>app) where I chose Storyboard) and a miracle happened

now it works


Good to hear. :+1: