xCode 11.1 crashes after opening existing projects

I guess you better wait updating to Catalina, because you won’t be able to open your existing projects. Or is it only me?

We discovered a bug in macOS 10.15 that where Xcode will crash if an xcode project has a “.hyperesources” folder within it. I assume this is your case?

We reported this to Apple as FB7107852 on August 22nd and I now see in the case:

Recent Similar Reports: More than 10

I believe this is more of a LaunchServices bug than an Xcode bug (and note that the Xcode 11.2 beta doesn’t fix it yet anyhow). The only workaround is to entirely remove Hype from your machine and reset your launchservices database. This will allow the project to open and not crash. Of course you’ll need Hype at some point, so before adding it back you can change the folder from “.hyperesources” to something else, but for the document to work you’d then also need to change all references in the .html and *_hype_generated_script.js files to the new name.

1 Like

Yes, that’s my case. So I’ll have to wait till Apple fixes it, or I could go back to Mojave. I updated because I was curious about Catalyst. :scream:

In my testing I was able to get this command to help without needing to trash Hype from my machine:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -R -f -u /Applications/Hype4.app/

(assuming you only have Hype 4 on your machine and it is installed in your Applications folder; if you have old versions or it is in a different path you’ll need to adjust)

I don’t know how long this command will stay effective for, and it may interfere with opening Hype documents by double-clicking in the Finder.

To re-register Hype 4 with the launch services database, you would use this command:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -R -f /Applications/Hype4.app/

But the funny thing is that after running this, I cannot reproduce the crash as I would have expected.

2 Likes

Thanks @jonathan. Since I’m not an experienced terminal user, I copied the command and pasted into terminal. If this is the right way to do it, sadly it didn’t help. If I forgot something, please let me know.

Hello,

When I do an Advanced Export Hype projects, it creates a “fileName.hyperesources” folder with my HTML file. In my past Xcode project when creating a Web App/webview project, I would simply copy the Hype folder and the HTML file into the Xcode project structure. This works in Xcode 11.1 with Mac OS 10.14.1. However when my newer MacBook Pro was updated to Mac OS 10.15, the project no longer works and simply crashes. I’ve tried a number of fixes. The one major observation I’ve been able to make is that Mac OS 10.15 and Xcode 11.1 do not like the folder naming structure. So, if I create a new Xcode project and copied over a Resource folder with a basic name like “test”, it’ll copy into Xcode just fine. If I try my “LLD_Ver2” folder (minus the “.hyperesources” in the name), it’ll copy over just fine. So, it seems like this configuration/OS update doesn’t like the folder naming structure. Now I can simply use the new name but then it messes with the Hype project expert references. Basically breaking a lot of functionality. Does anyone have any suggestions or experienced this? Thanks!

Hi @CuteGuineaStudio,
moved you to this thread, please read above

1 Like

Thank you. I’ll give it a try and let everyone know.

You guys continue to be such a huge help! The Terminal command worked beautifully! All three of my Xcode projects are now working. I am now able to use my original project files without issue. Thanks again!

1 Like

In an “ideal” situation where you’ve only had Hype 4 installed in the Applications folder, this would probably work. But there might be other issues that are preventing this single command from working. I’d probably try these steps:

  1. Remove every copy of any version of Hype from your machine, though you can leave Hype 4 in the /Applications/ folder
  2. Restart your computer
  3. Run this command to reset the launch services database:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain u -domain s -domain l -v
    
  4. Restart your computer again for good measure
  5. Run this command to de-register Hype 4:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -R -f -u /Applications/Hype4.app/
    

Now you can launch Xcode and see if it works.

These commands mess with essential system databases, so run at your own risk.

It is really a shot in the dark at a workaround honestly… Apple should just fix the bug. Catalina is a mess.

It took some time before I was brave enough to try again but, YES it works now!
Thank you @jonathan

1 Like

FYI… The recent update to Xcode 11.2 required me to re-run the Terminal Scripts.

That might be expected; we’re essentially removing an entry from a database that gets auto-populated, so it is isn’t clear when the entry might revive.

I opened Xcode today and it appeared to have happened again. :disappointed: This time, the script doesn’t appear to be working.

Same for me. Try unregister (The latest from @jonathan with the kill) and directly re-register. Worked for me.

Yep. As you can see from above, I ran into this when upgrading to Xcode 11.2 and this fix worked like a charm. However, just a day or two later, it started all over again. I retried it several times today and keep getting the error. Ugh!!!

BTW… I’m on Xcode Version 11.2 (11B52) & Mac OS Version 10.15.1

I also re-installed both Xcode and Hype 4.

What works for me:
first unregister, then de-register.
Open your project from Finder. Right mouse button: open with Xcode
If you do not close the Xcode app, you can keep on using it until you restart your Mac.
It’s also possible to just start a new project with the @MarkHunte template.

FYI. I just noticed that there is another update to Xcode. I’m on version 11.2 and it looks like there is an 11.2.1 version now. I’m going to give it a try.