Solved: Hype Crashes on Preview or Export (bundle repair Terminal Command)

Hype 3.6.2 Pro crashes always on preview, with all the browsers, with all projects. I can export without problem but not preview.
Mac OS Sierra 10.12.4 French

Any answer to this ? Thanks


I did fresh reinstall, complete preferences and app data remove. Same…

@manuel and @drewbullen

Please try this:

Close Hype, Open the ‘Terminal’ application in the Utilities folder under Applications, and run:

asctl container repair --bundle com.tumult.Hype2

Reopen Hype.


Yes that worked - after also nuking license etc

1 Like

It works, thanks !

1 Like

Hi Daniel! I’m having the same issue on Hype 3 Pro since an Update (crashing on preview in all browsers): I’m using 3.6.3 on OS X Sierra 10.12.6. Everything is up to date.
I think a fresh install of Hype could solve the problem but I’m having trouble finding the suggested folders and files in the Library. It seems different in Hype 3. Can you help me on this?
Thanks a lot!

Happy to help out. I’ll send you a private message.

Hey Daniel. I’m also running into this issue right now and I’m unable to locate the folders, as well. I’m currently using Hype v3.6.3 on macOS High Sierra 10.13.1. Please advise as to how I can remediate this issue. Thanks!

When you follow these instructions where does it not work?

Thanks, it Works

1 Like

Dan: I sent you a file on this problem yesterday, but then just found this post. It worked, so ignore the file I sent you. (everybody always says: look for previous posts about problems)…and its true!

I just ran into this issue. The terminal command fixed the problem.

What’s the technical of this solution? Why does this problem occur? What is the terminal command and what is it doing to fix the problem?

MacBook:~ Photics$ asctl container repair --bundle com.tumult.Hype2
Beginning repair of: /Users/Photics/Library/Containers/com.tumult.Hype2
   Rebuilding container...
   Migrating application content into container...
   Saving updated container information...
   Rebuilding sandbox profile...
   Repair completed.
MacBook:~ Photics$ 

I tried searching and asctl leads to IBM software Aspera – “High-Speed File Transfer Software”, but I don’t know if that’s related.

Is this problem common? Maybe I should cover it in a book update. Searching for the solution to this problem is not so easy… not with the forum search alone.

It is a bug in the Mac App Sandbox technology.

Last we heard from Apple they suspected it hits Hype because of how we capture logs (and the irony is the reason we do it in the manner we do is because of the app sandbox), but we haven’t gotten details on a workaround or if they intend to fix yet. I do plan to investigate different methods to get our logs in v4 if there’s something else cross my fingers it will work. I haven’t been able to reproduce the conditions creating the bug in contrived “lab” settings, so any fix is a shot in the dark.

(as a side note in case there’s cause for concern, Hype’s logs are only sent manually by users via the Report a Bug/Feedback/Crash mechanism, but are quite critical in investigating issues and supporting users)

A side note to the side note… it didn’t trigger the Hype reporting. It would just crash. I could use Apple’s reporting to send a crash report, and I sent a bunch of those, but the Hype crash reporting popup didn’t appear.

Thanks - actually even if it did detect a crash it wouldn’t be able to report it in this state :-.

Hi, I was encountering this bug, and fixed it with the terminal solution. Only problem is now I have the trail version instead of my purchased Hype app. Could i please get a free serial number so i don’t have to repay?


Hi Connor, I’ve sent you a private message to resolve this. Thanks!

Hi Daniel,
The terminal command worked.
Sorry it took me so long, I was travelling.
The project is with that weird behaviour thou.