Problem with JPEG in Symbols


(Wolfgang Wunderlich) #1

I have a problem, I can not solve:
I want to insert a JPEG into an existing project with symbols.
I can import into the main timeline and it´s visible but it´s not visible when I import it into any symbols.
It is there, so I can see the marker, but it´s not visible, even though its on the top of the list and all possibilities are set to visible.

When I start a new project and in there a new symbol … it´working, but not in the existing project.

(I can send the dropbox-link to the zip by mail)


(Daniel) #2

I’m not able to reproduce the problem you’re describing.

About the existing projects: Did you create with a previous version of Hype?

Have you tried checking the ‘Content overflow’ setting of your object? Maybe try switching it to another option, then back to ‘visible’ again - just to be sure.


(Wolfgang Wunderlich) #3

Hi Daniel,

thanks for the reply.

Yes, the project was started prior to PRO Version and continued in PRO.
Content overflow has not really an effect, but it may have something to do with ist, cause the JPEG has unusual dimensions: 3886 x 113 (its a sliding picture).

I hope, its not due to the older start version cause its a pain, to transfer everything in a new project. And Tumult did´t mention anything about incompatibility.


(Daniel) #4

Personally I didn’t run into any compatibility problems working with older project files and newer versions, but nothing is perfect so we can’t say for sure :wink:

Of course it’s unwanted work to transfer everything to a fresh project file, but maybe you should try just that to check if the error still occurs.

A good way of getting most of it safely to a new document is to select all layer entries of the timeline, copy them and then paste them into your new file, right clicking -> ‘Paste with Animation’.


(Wolfgang Wunderlich) #5

Thanks Daniel

yes, I would have done it, but it´s some kind of komplex so i rather have to continue.
But I have recognized, that the JPEG is visible in the final HDML export, just on the workingspace NOT.
So its a little tricky to work, but with trial and error its not impossible.

Perhaps this is a topic for the software maintenance cause it seems tobe some kind of a bug.

Thanks for you´re effort.
W.

If anybody has an idea, how to make it visible on the workingspace … feel free, its
highly welcome.

But I have another Problem in using Symbol … it seems to be not possible to trigger any element outside the Symbol, such as a timeline, not inside the symbol, even you can select it. (on click, do this… or that).
It selected, but it does´t work.
Is that so ?
Or is that also because of the non compatibility to older projects ?

Do I have to understand a symbol as a wallet garden ?
Unfortunately also the “Book about Hype” tells nothing about such things.


(Mark Hunte) #6

You could try a Restore from the exported folder. This will give you what you have already but should build the project anew.

Try two ways.
Export the document without the added JPEGs. And one with.

Then go to the Help menu-> Restore Document from Export.

Nav to the folder contains the exported .hyperesources folder, select the folder and open.
This will recreate the Project and hopefully flush the bug.


#7

A symbol is sort of a walled garden, as you said. Think of it as a scene within a scene. A scene cannot control timelines outside of it, unless you use Custom Behaviors.

With custom behaviors, you can control anything in any symbol (or non symbol) if it exists in that top level scene. If you want to use a symbol to play the main timeline of a regular scene (where the symbol exists), go to that scene and create a custom behavior (in the scene inspector):

Next, go into your symbol, and click an element, and you’ll see that the custom behavior is available there:


(Wolfgang Wunderlich) #8

Hi Mark,
Thanks for the hint … I just tried ist … but no… does´nt work.
The import remains inviable, also in the recovered version.

@Daniel
Thanks for the Information, good to know.
I will test it and i´m sure, to find a way.
Hype is really good to work with.

The nice thing on this forum is, that it seems to be the most efficient way to learn.
Thanks to the help, of the nice folks around.
Reading and the tutorials seems to me not really efficient regarding the Hype product.
So, thanks for the help.


Hype Documentation
#10

I welcome criticism on our written documentation, since most words are mine – technical documentation is hard to get right. It’s a balance of writing for non-technical users, and links to additional content for those who want a bit more detail.

If you can share you’re document we can help you out. We’re flying blind.


Hype Documentation
(Wolfgang Wunderlich) #11

Hi, Daniel

I have it on:

but its in rough working condition far away from final status.
I was trying, to insert in symbol: Showcase Kapitel the JPEG "Chapter 1`.
As you may see, it works on the front as a test, but not in the Symbol.
It is not visible in the working space, how ever its visible in the HTML export,
But ist really hard to work, if you´re flying blind.