Local HTML files with Android

android

#1

Hello, this is Teresa, recently we have been experencing some problems with Android and hype html5 when opening LOCAL FILES, in the past we had no problem, but now, we lauch the index.html locally and there is only a blanck page, we don’t know if it is because a upgrade of the OS or because some adjustment in the SAMSUNG GALAXY.

Something the boders us is the URL that is not the usuall ones, it seems that are enconded by the OS with something like this content://0@media/external/file/4649

Even if we try the simplest (project we greeting text in the home page) we still recieve a blank page.

In the past, whe we reset the tablets it seems that every thing goes normal, but still don’t know the origin of the problem so that when anyone of our users get the blanc page, we can tell them how to solve this problem

Best Regards


#2

Exactly the same problem here on LenovoTab 4.

Plain html without any js or css does seems to open and render with a strange url (content:// media/external/file/9999). No Hype though.


#3

Does a simple .html page without JavaScript and a single image reference work for you?

Do you see any errors in your browser console? You should be able to connect with a USB cable to see what the browser is having trouble with: https://developers.google.com/web/tools/chrome-devtools/remote-debugging/

Another alternative is to use one of the kiosk programs here: Displaying a Tumult Hype document in a Kiosk or as an app


#4

I tried to use the chrome remote debugging but could not connect the device. Anyway tried a simple HTML with an image. It gives me a broken link even if the image is in the same folder as the HTML-document.


#5

It may be that android changed how their browsers work with references — are you loading the files straight from the file browser?

What is the URL of the referenced image if you open it directly? (And how does this compare to the HTML file’s URL)


#6

Yes I clicked the HTML the file in the file browser and made a choice to open it in Chrome.

Android file URLs seem to be sequential.
If the HTML flie is:
content://media/external/file/100
then the image is:
content://media/external/file/101

Looks like that Android is changing all the file names to ordinal numbers. :dizzy_face:


#7

Hello Daniel. The same html without images, only with a text. We see it online perfectly. When transferring it to the tablet with samsung application (Smart Switch). Convert the link. the only way to fix it is to format the tablet. I have a master in kiosk applications, I like Offline pages.


#8

I don’t know how to workaround this weird behavior.


#9

Solution:

  1. Use Opera browser.
  2. Save as homescreen app.
  3. Enjoy!