GIF export never finishes - Using Older GIF Export Engine


(Trey Yancy) #1

Several times I’ve tried to export animated GIFs but after the progress bar completes, nothing happens. I can see the progress bar strobing as if it is processing, but it never ends.


(Jonathan Deutsch) #2

If you can post (or email support@tumult.com) your .hype document, that would be useful.

In v3.6 we changed to using a tool with better colors/filesize, but sometimes an export can take a ridiculously long time in the last step (and I guess potentially forever if you are seeing that!).

There is a method to use the older GIF export, should you ever hit issues via this terminal command:

defaults write com.tumult.Hype2 AnimatedGIFEngine Apple

For anyone experiencing issues, we’d appreciate a bug report via Help > Report an Issue… before changing to this method.

To change back, you can use:

defaults delete com.tumult.Hype2 AnimatedGIFEngine

Unable to export to gif or movie
(Trey Yancy) #3

That’s it. I tried to export it again. From the time the progress bar finished to the completion of the job was around four minutes.


(Jonathan Deutsch) #4

Out of curiosity, what are the dimensions, duration, and framerate of the animation you are exporting?


(Trey Yancy) #5

600x400, main TL 4 secs, 2nd TL 6.5 secs.

BTW, the GIF that took four minutes beyond the completion of the progress bar was a different file. Processing the GIF for the fireplace example took a quarter of an hour.


(Jonathan Deutsch) #6

Thanks - that is a bit of an absurd amount for such a short animation. Aside from changing the method with the defaults command above, if you choose a FPS that is evenly divisible by 100, it will be faster. There’s an extra step that happens when it isn’t divisible by 100 and that appears to be taking a large bulk of the time.