Exporting to Google Sites


To add your Tumult Hype document to a Google site, follow these steps:

  1. Allow embedding in your site settings by following these instructions: https://support.google.com/sites/answer/6024145?hl=en
  2. Upload your Tumult Hype document to a web server. Here’s a guide and video to uploading your Tumult Hype document to your site: Video tutorial: Uploading your Tumult Hype document to a Web Server and Embedding Within Another HTML Page
  3. You’ll need to make sure that your document is accessible via https. (https://site.com/document.html). Using Dropbox’s public folder is a quick way to do this if your server does not enable it. Use File > Export as HTML5 > Dropbox
  4. Go to the page you want to add your document, and click in Insert:

Then select:

Lastly, insert the URL of your site and make sure the width and height match.

Exporting FAQ: Guides for exporting to Websites, Apps, Content Management Systems, and more
(KateW) #2

Thanks for replying so quickly to my tweet.

So I don’t know why but this isn’t working for me:

Here is the HTML: http://ettsummit.org/sandiego16-googlesite-speakers/sandiego16-googlesite-speakers.html

Then the XML I made: http://ettsummit.org/iframegadget.xml

Then I added the Widgit to the exact dimensions from Hype, 850 x 700 and still nothing.


Hmm unfortunately it doesn’t appear to be working like it should anymore. Testing some other ‘gadgets’ – I have a feeling that Google Sites doesn’t get much love from Google.

(KateW) #4

Sadly I fear that too. Thanks so much for getting back so quickly!


Try setting this property: https://support.google.com/sites/answer/6024145?hl=en

(KateW) #6

No luck…


Just updated the instructions. No need for XML document anymore – but make sure you use an HTTPs URL.

(KateW) #8

YAY!! It Worked http://ettgoogle.org/sandiego

(Pat Gombarcik) #9

Hi, I really like your Hype project. I wanted you to know that when I look at the top link where it is all by itself it works great, but if I go to the actual website it is cut off on the right side. I am using an iPad in case that makes a difference.