Adding fonts-not displaying correct font


(kim) #1

i’ve tried everything i can to add Aviano/with hype2 it worked from typekit first pop!
now i have hype pro-although it will say its there/when i go to type,its not the right font.
I’ve tried everything i can find online about 5 different ways with same outcome!
does the same with another font i tried bodini 72 old style.
with fireworks it works/with hype 2 it worked-im out of ideas/handcoded the crap outa it-i can’t get it it working.
i need aviano font as its my brand and I’ve trademarked it also.
i bought the font from my fonts and have it on typekit also-im lost!!!


#2

Can you share what you have so far and your font files?

http://tumult.com/hype/documentation/ has our Typography Documentation, which should help you see how to get custom fonts working in Hype.


(kim) #3

I’ve sent you my whole font book-as you said you wanted my font files!
is this what you mean-pretty hard to understand when you don’t explain what font files?


(kim) #4

well I’ve just wasted another day trying to get this working/one of your links has expired tried to follow first one no luck there either

tried to get files into resource library-cant do that either


(Tanuj) #5

Hi Kim,

What exactly do you mean by this? Are you not able to use the file after getting into the resource library, or not able to get it in at


(kim) #6

i endend up fixing that/because i changed from CC to buying CS6 adobe froze my typekit.
so i went to my fonts updated my webkit there and all was good.

the trouble I’m having now is fonts from my OS not displaying correctly-seems bodoni 72 and source sans pro are both displaying the same font which looks to me to be trajan pro

honesty you’d wonder why tumult dosent make this all work automatically without stress to the user!
(my five cents worth)


#7

Hi Kim,

http://tumult.com/hype/documentation/3.0/#typography

Here is the link that goes to the Typography section in the documentation for Hype 3 (Pro)

In my experience people forget to put in the ${resourcesFolderName} in the code when referencing from the resources folder, not to say this is what you’ve done :slight_smile:

Can you explain what you’ve done? Maybe a working document or an example of what you’ve implemented. And also your font files if you can/ want. The .eot / .svg / .ttf / .woff files and also the css code if you added your fonts using custom css.

I think this is what Daniel was referring to in his post.


(kim) #8

hi DBear,

          ok how do i give you a working file? now I'm just trying to add fonts from OS.

sorry I’m totally lost-i don’t have a clue what I’m doing.
when i try removing the stuffed up font from hype they disappear from my font book.

honestly i need a movie of how to do it lol


#9

can you upload your hype file here?

Just compress it to a zip and drag it over the reply box

D


(kim) #10

lol,
and how would i compress it to a zip Daniel?

you guys say things that between you all may sound simple but to me its
"chinese" lol

what button do i push to do that-i can’t find a save to zip file!

im frightened to loose my project by randomly pushing buttons!

regards kim


#11

ok Kim,

Don’t worry

FYI save your document, look for it in the Finder on your computer and then right click and choose Compress "Your File Name Here" and it will make a .zip of your file. But, follow below on how I add a font using the Custom CSS route in Hype.


I’ll try and walk you through how I would do it

  • I would download my font from my favourite site and end up with a file with an extension (.ttf / .oet) etc.
  • I would then drag that into my resources window in hype
  • I would then navigate to the Typography inspector and click on

Now as you can see below I have the font “AlexBrush-Regular.ttf” in my resources folder. I am now going to fill in the “Add more fonts…” box


(kim) #12

Thanks very much,
my custom CSS fonts are working great-it’s
the OS ones that are playing up now to be specific

Bodoni 72 old style italic which is the only one I need to work correctly

Which is an apple font/one would think it would work straight off the bat!

I could code them in later although it does defeat the purpose of hype in
the first place!

I appreciate your help immensely DBear

Regards kim


(kim) #13

my nightmare continues-OS font not displaying correctly-i could handed a whole website under the time i’ve spent trying to get the fonts i need to display correctly

fireworks perfect–hypepro—nightmare


(kim) #14

Finally got to the bottom of it all!
I’d bought and installed hype2
hype2-3 Beta
hype3 on itunes
hype3 pro
they were all working against each other so nothing was really working correctly
none of the things people were trying to help me with made sense as the programs were all intertwined/stuffing up the simplest of things.
So i trashed the lot-downloaded hype pro again and the clouds cleared/the fonts I’ve been trying relentlessly to add–i added and the worked as the should/straight off the bat.
So although I’m happy as larry/i feel a little stupid spending nearly an entire week not only wasting my time but everybody elses.
I thank those of you who helped or tried to and i apologise humbly for wasting your time.
hype pro has to be the best software invented so I’m glad I’ve finally got a handle on it!


#15

I moved 2 posts to a new topic: Typekit Local Fonts not appearing correctly in Hype: Yosemite 10.10.4