Working past Chrome Autoplay 66 limitation


(BKessel) #1

With the release of Chrome 66, several of my delivered projects are now broken. I’m playing a song or sound when a scene loads - but this now doesn’t work. Connecting to a button works but this is just an added step for the user - even confusing.

I’ve tried assigning the “Play Sound” action to the timeline, but that doesn’t work either.

Is there another javascript or other solution?? It seems that functionally, assigning playing a sound to another action other than “mouse click” should work similarly.

Using a project with several scenes, If I use a “menu page” say in “scene 1”, can I use that “mouse click” action to begin playing audio in “scene 2” then transition to scene 2?

This is pretty frustrating change by Google.


#2

True.

I would think assigning the action to a Mouse Click should solve. Perhaps a Mouse Click to the next scene with a “Play Audio” attached would overcome this obstacle.


(BKessel) #3

Wasn’t thinking clearly; apparently I didn’t use scenes on the project I’m scrambling over - separate files accessed with “goto URL” action. Luckily, I’ve tested some ‘copy/paste with animations’ and it seems I can quickly go to a multi scene approach.

Does this affect autoplaying video as well?


(Jonathan Deutsch) #4

Video follows the same restrictions if it contains audio. If it is muted or does not have an audio track it is allowed to autoplay.

As a side note, please make sure to be using Hype v3.6.7 if you’re not already - it more properly handles the Chrome audio changes.


(BKessel) #5

I’m definitely using v3.6.7 and thanks!

But there is still no autoplay ability, even utilized delay start via timeline or other.

I using Hype for stand alone kiosk development. In several cases there is no ability to “initiate” a response from the user.

Is there some workaround for this?

Has Tumult contacted Google Chrome team this issue?

It would be appropriate for folks utilizing the “–kiosk” switch to have autoplay ability enabled. It seems more directed to web based visitors.


#6

I’m assuming your on an Android Tablet in a Kiosk situation? Let me know if not. You can change these settings in Chrome if you control the device. Open:

chrome://flags

Type ‘Autoplay’

And select the ‘Autoplay policy’ option.

Next, change the property to the following: