Wordpress embedding is not always working!


#1

It is crazy - I worked after looking video tutorial!
One example is working - now I would like to change file - but even I made in same way is not working

I give up in this moment - I spend 2 hours for no result.

javascript code is to see - in example one is working - other example no


#2

Can you share the code you used to embed? And also the URL of the page?


#3
<div id="weinspielereiani1_hype_container" style="margin:auto;position:relative;width:100%;height:200px;overflow:hidden;">
	<script type="text/javascript" charset="utf-8" src="http://neu.weinspielerei.com/wp-content/uploads/2017/hype1/weinspielerei-ani1.hyperesources/weinspielereiani1_hype_generated_script.js?30035"></script>
</div>

working


#4
<div id="wpani3_hype_container" style="margin:auto;position:relative;width:100%;height:100%;overflow:hidden;">
	<script type="text/javascript" charset="utf-8" src="http://neu.weinspielerei.com/wp-content/uploads/wp-ani3.hyperesources/wpani3_hype_generated_script.js?33095"></script>
</div>

not working


#5

@rose_puc

I noticed in the code that is “working” You have the height set to a fixed pixel size.

The “not working” version uses a percentage for height.

I do not use Wordpress & Hype but this “fixed height” scenario seems to be an important part of a Wordpress set-up based on my past readings.


#6

It should be work also for flexible layouts…
So I cannot work with hype. In this case the second animation looks better if drawing window - all elements stay in their positions - at first animation: elements are not always on their positions and are moving.

Perhaps I’ll try Adobe Animate CC or embedding with Iframe (but this solution is not my favorite).


#7

Hey @rose_puc, as Jim mentioned, the issue is that the container you’re placing your Hype document into needs to have a minimum height. When you have a height set as a percentage, the height becomes 100% of 0px, which means that your document won’t appear. So, you could either set a minimum height for that container (by setting min-height:400px or something appropriate on your Hype div) or build your layout so that it doesn’t need a responsive height.

This video explains how to set up a flexible document for wordpress embedding: https://youtu.be/CuwkJTtuGLc