White text background


(Trey Yancy) #1

When changing text justification a while fill appears behind the text. When this happens, the only recourse is to throw away the element will all its animation and settings and recreate the type element from scratch. This has been an issue for a good while. Any suggestions?


#2

Sometimes white backgrounds can be added when copying and pasting elements, but I haven’t heard reports of white backgrounds being added when changing the justification. Can you share your document where this is happening and point out the element?

To remove the white background, you can remove any extraneous CSS or HTML that is not your text by selecting your text box and then clicking Edit > Edit Inner HTML. Then, make sure that only your text is in the text box:

On a a housekeeping note, can you set a category for your posts?


(Trey Yancy) #3

I recreated the problem. What I found was a background-color tag. The question is, why is this being inserted? I get this when copying text from the same block of text and pasting it back in.

When trying the same with a block of text using a Google font, the code for the font is also inserted in addition to the background-color tag.

Sorry about the category. Bad habit from not finding a suitable category in a couple of previous posts. Thanks for the heads-up.


(Markus Bjerre) #4

I had the same problems a couple of months ago. I ended up pasting the text into the inner html instead, and then use basic html tags to break lines and change font size etc.


(Trey Yancy) #5

I’m working on a relative site with six text boxes on each of four layouts (not counting tag lines and titles). If I update the text on one the options for the versions in the other layouts is either to manually type them in or paste and resize the text, remove all the html junk, get out of the html editor, reinsert paragraph returns, then make whatever formatting changes are needed. This does add up. If a fix coiuld be worked into Hype 4 I’d love it…


#6

I’m sorry to revive this issue as I believe … yet it was not fixed since V. 2.5;


(Armelle Boy) #7

“…a while fill appears behind the text.” I have the same problem…


(Mark Hunte) #8

@armelle
Have you opened the innerHTML view on the element and checked whats is in there ?


(Armelle Boy) #9

Ok, there was “background-color: rgb(255, 255, 255)” in the innerHTML !
Thank you Mark !


(Trey Yancy) #10

You can use the paste and match style command in the edit menu and you can copy and paste from a text document.

One thing that I have seen on occasion is that switching the text alignment can cause this to appear as well. In such cases, I have had to go into the HTML and clear out the junk.