When using export scripts i cant choose external runtimes anymore

exportscripts

#1

Hi there,

in latest hype using advanced export and the export scipts the possibility to add an online runtime is greyed out now.

I use to export to SIZMEK alot and they offer HYPE online runtimes from their servers. Please make it available like in the last versions.

Thanks in Advance.
T.


(Jonathan Deutsch) #2

I assume you mean when using the Advanced Export? Try re-downloading and installing the Export Scripts with Hype v3.6.3 and see if that helps. I made new versions ~a week ago that should allow this.

(in theory it should have notified at some point there was a new version of the scripts)


#3

Hi Jonathan,

installing the latest package solved it. Thanks! I didnt get notitified that there is a new version of the script tho.

Is there an update checker for those scripts?

Besides it would be nice to have an AdForm export script. :wink:

cheers,
T.


(Jonathan Deutsch) #4

In theory the script will check once a day on export, but it looks like they were hitting an issue with how the check was done against our production CDN. Unfortunately the only fix is a script fix, which folks won’t know about! I recommend grabbing the latest versions now, that has the working update check.

Thanks for the request about AdForm! It is on the to-do list.


#5

hi jonathan,

downloaded latest SIZMEK export script (hopefully the latest ;)).

i can add an external lib url but the link wont get added as source url in the generated *.html file. check here:

i have to change it by hand right now. doing so for around 80+ banners is a bit of pain in the a**. :wink:

Cheers.
T.


#6

You can uncomment the external URL lines around 158 and 184 in the script to include your own external CDN url in the script itself: https://github.com/tumult/hype-export-scripts/blob/master/Sizmek/Sizmek.hype-export.py#L158


#7

thanks! that will do the job!

Cheers,
T.


#8

Hiho Daniel,

no luck.

changed line to

cdnPath = "https://secure-ds.serving-sys.com/BurstingcachedScripts/libraries/hype/584/" + args.hype_build

reloaded hype but html still looks like this:

type=“text/javascript” charset=“utf-8” src="./HYPE-584.thin.min.js"

:frowning:

Cheers,
T.


#9

Can you make sure you have the latest version from the hype-export-scripts repository?

Line 177 through 194 for me is set as follows and it works for me:

if args.get_options:		
	def export_options():
		cdnPath = "https://secure-ds.serving-sys.com/BurstingcachedScripts/libraries/hype/" + args.hype_build
	
		return {
			"exportShouldInlineHypeJS" : True,
			"exportShouldInlineDocumentLoader" : True,
			"exportShouldUseExternalRuntime" : True,
			"exportExternalRuntimeURL" : cdnPath,
			"exportShouldSaveHTMLFile" : True,
			"exportShouldNameAsIndexDotHTML" : True,
			#"indexTitle" : "",
			"exportShouldBustBrowserCaching" : False,
			"exportShouldIncludeTextContents" : False,
			"exportShouldIncludePIE" : False,
			"exportSupportInternetExplorer6789" : False,
			"exportShouldSaveRestorableDocument" : False,
		}

#10

Hi Daniel,

i donloaded latest export package to be sure and uncommented the line again.

it wont get added to the index.html. no chance :frowning:

Kind regards,
T.


#11

Hi Daniel,

me once again. Still no luck. If i uncomment the options like you did all options in advanced export is greyed out no go.

i see in your settings:

“exportShouldUseExternalRuntime” : True,

this is set to False in my script (even in the version online on github)

Setting to True has no effect…

Kind Regards,
T.


#12

Sorry about this – this is a bug in how we inline which conflicts with CDN usage.

If you change "exportShouldInlineHypeJS" to False in the export script this should allow you to use the runtime on the CDN. Alternatively, you could modify the incorrect reference to load the CDN version.