Very Strange bug corrupts even old files

I have been working for months on a very complicated website that has multiple symbols, behaviors, scenes etc. Until a few hours ago, everything was fine when previewing in browsers, then suddenly, one Persistent symbol named “AlphaMenu” stopped working as expected.

So I opened a copy from earlier this morning when I know it was working fine, but it has the same error. So I opened older copies, even ones from early March, when I t was definitely working, and all of a sudden that AlphaMenu symbol has the same exact error. All my backups, from months ago, that didn’t have that error, now when I preview them they do.

This is a sample file, much simplified, yet it has same issue when I preview it. Menu opens on the next Scene automatically, even though there’s a Pause at 00.01. (82.0 KB)

This is a new file I just created with the same functionality for the menu, built from scratch, and it works. (85.0 KB)

The original though, is corrupted everywhere, even in old files that were fine before, even in new files. I’m at a loss of ideas as to how this could be happening. How can Hype corrupt a persisten symbol on any file it appears??

Any help would be very much appreciated!

It looks like this is caused by the 4.0.4 update that we just pushed out this evening (but haven’t yet announced). I’m working on a fix.

Aaaah. So it was pushed out Tuesday night? That would explain it.

Yes, please if you could fix it that would be great. Or anyway I can reverse to previous version?

Have you tried time machine?
You may be able to restore one of the originals…

Then zip it. And use a copy from it in future.

I normally try and save core projects out also as a template.

I was able to download Hype 4.0.3 but since I originally purchased it through the App Store, I only have it for 14 days. How can I enter a license?

And yes, 4.0.3 did resolve the issue.

Yep, didn’t work. Turns out it was the Update 4.0.4.

Downloaded previous version 4.0.3 and that fixed it. Took me a few hours though, so that wasn’t fun. Also, since I originally purchased it through the App Store and this old version I can only get form the Tumult Store, I don’t have a license for it.

Hopefully the App Store version will be fixed soon.

I know that. I misread and assumed when you said version you meant the hype project

So I was talking about restoration of the original file if permanent changes were being made to the file when opened in 4.0.4.

Tumult Hype 4.0.5 with a fix for this issue has been submitted to the App Store.

You can get the direct download version from:

(@julian, I’ll DM you a license to use with that version)

Sorry about this issue - this particular bug slipped through the cracks. Please let me know if you see any other problems with 4.0.5.

1 Like