Uncheck Loop playback does not work as expected

Hello @jonathan

Please check the screenshot:

I am trying to expert a GIF, and the trigger is set to be “continue timeline”, that means the headline animation should be play only once, also I unchecked LOOP.

But you will find the Head text animation will still loop, that mean the GIF still loop, right?

Technically, Is that expected behavior please?

Here is the file for your check.

Thanks

ranning.hype.zip (386.6 KB)

Since you’re not ‘viewing’ the document, I don’t recommend using ‘enter viewport’ for creating GIFs. You can switch the ‘Headtext’ timeline to start ‘on scene load’ instead.

If you uncheck ‘loop’ in the GIF, it will stop after playing a single time.

Thanks.

It is really great way to play a timeline just for once.

I understand.

what about if I just want to export a GIF image with the spray raining LOOP and the head text only one time? is that possible please? :slight_smile:

Here is what I set:

but the headtext timeline will loop too.

Thanks

No, this is not possible to do via a GIF. The GIF can either loop entirely, or not loop. There’s not way to say “run fully once and then just loop from this point” in the GIF file format.

The only “workarounds” – both unacceptable – would be to have a really long GIF that itself does not loop but contains the animation for your looping timeline, or to use a series of two animated GIFs.