Unable to modify text


(David Guillermo Escalante Trinidad) #1

Each time I make a new text box, im unable to modify its content, at least not by the usual means, the only way I found (unless this is how Hype its supposed to work) its by editing the “HTML content” inside the text box.

While I can face this text editing model, as complicated it is, it makes hard to set certain works in different font styles or color (yes, I know I can set color via HTML, but I bet i can be easier using Hype GUI tools).

Is this a bug? Im doing something wrong?

Here is the video of the error, I call it an error because I was able to modify text before as in any graphic editing software:
https://dl.dropboxusercontent.com/u/67104790/video_capturas/hype_bugs/cant_change_text.mp4


(David Guillermo Escalante Trinidad) #2

Never mind, I found that FOR SOME REASON, text is not editable if it is inside a Symbol, so I stand that its a bug, but at least I found a solution: Edit the text outside the symbol, cut it and paste it inside the symbol again.


#3

@Davirus

I have no problem with changing the text inside a symbol. I downloaded your example file https://www.dropbox.com/s/kopt9n4y5pfpccn/test_highres4.7z?dl=0 from the “MacPro 13.3 = iPad” post (appears to be similar to your video above), but could not open it. Would You provide a Zip file here to test?


(David Guillermo Escalante Trinidad) #4

You are going to believe im crazy, but it wasn’t working, but now it is, indeed I can edit text inside symbols.

But this have been happening the whole day, sometimes it works, sometimes (most times) it doesn’t.

Yet, here is the hype file inside a zip file: https://www.dropbox.com/s/xu2ud0o5wwh3cs6/test_highres.zip?dl=0


#5

Now you’ve officially joined the Asylum… with the rest of us ;->

BTW: The file You just linked to above is a “.mp4” not a “Zip” file.

Edit: I see the change just now - thanks.


(David Guillermo Escalante Trinidad) #6

Jesus!, I may need a rest, I edited my previous comment with the right link, sorry.


#7

@Davirus

Glad your issue has resolved itself.

Just for the record: I tried editing text boxes inside of several different symbols and all worked.


(David Guillermo Escalante Trinidad) #8

Thanks, I will try to find a way to replicate the error, but so far I expect it never happen again, its way too annoying.


(David Guillermo Escalante Trinidad) #9

Well, it happened again, no idea what caused it, but closing and opening Hype doesn’t fix it, Im assuming it will fix it self again, just wanted to mentioned it since it shows a different behavior, but the problem is the same:

https://dl.dropboxusercontent.com/u/67104790/video_capturas/hype_bugs/bug_strikes_back.mp4


#10

What I’ve found in a further (brief) random search through the layers of your project file…

Symbol: "Anim - Cambia chip"
The button “Boton Cambia Chip” is covering the text boxes “¡CAMBIALO!” and “Haz clic aquí” which is preventing direct editing. If I hide this button (the “eye” icon in the layer) I can then edit these text boxes directly.


#11

If it happens again … suggest sending it to Hype using Help -> Report and Issue and “Attach Open Hype documents” fill in any relevant information.


(David Guillermo Escalante Trinidad) #12

Thanks, I will.


(Jonathan Deutsch) #13

Thanks for filing the bug, I was able to take a look. Here’s my reply so everyone can see:

This is a recent regression in Hype and we plan to have a fix in the next released version. The issue comes about when you have an element above the one you’re trying to edit; even if it is locked or not part of the current editing symbol it gets in the way with making a selection. The workaround is to temporarily hide visibility of the above items or edit via the Inner HTML.


(Pat Campbell) #14

I found the only way to RELIABLY edit text is to click on the text field then select edt>edit element and then use the arrow keys to move around the text field. I use shift arrow to select text within the text field.