Troubleshooting Tumult Hype Wordpress Plugin

The “Views details” link points to the old plugin page.

Are you taking that over? :thinking:


Upload limit could be a problem for some people. The upload_max_filesize setting is only 2mb on my server.

Also, I wasn’t able to catch a screenshot in time, but the progress bar for file uploaded wasn’t aligned properly.


I tried using the plugin.

Nothing displays when using the “div” option…

I get the following error message…

EvalError: Refused to evaluate a string as JavaScript because ‘unsafe-eval’ is not an allowed source of script in the following Content Security Policy directive: “default-src ‘self’ ‘unsafe-inline’ data: https://photics.com”.

…and the project doesn’t appear properly when using the iFrame option…

It doesn’t set the height correctly. It stops at 150px.


Console Log from /wp-admin/admin.php?page=hypeanimations_panel

[Log] JQMIGRATE: Migrate is installed, version 1.4.1 (load-scripts.php, line 9)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (sort_both.png, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (sort_asc.png, line 0)

I uninstalled the plugin. It’s not much different than before and it doesn’t really work for me. It would have been nice to have a single file for the project, but it’s not compatible with my security settings (I didn’t know what to put for this https://wordpress.org/plugins/wp-content-security-policy/ module. Even adding ‘unsafe-eval’ didn’t work. It only made the text on the page larger and the project didn’t display.) and it doesn’t simplify the project scaling (responsiveness) issues. (It’s hard to place a project that isn’t a fixed size.)

On our server that number is 200 but sometimes hosts are nice about upping that limit. We just read a property in php.ini.

What are your document / responsive settings on scene 1?

K? Unclear why you posted issues but uninstalled? Get back to me if you want to help test and fix issues with this.

Anyone know how to change the limit in PHP.ini, and also there are a lot plugins support do that, please check here: https://wordpress.org/plugins/php-settings/, 300MB should be prior choice for Wordpress standard.

For now, I can not activate hype-wordpress-plugin-master, but if you have limited the size to 2M, please remove it or allow large size.

If someone take security into consideration, please use the IP-Geo-Block, and it is easy to handle what kind of roles can upload files, here is reference: https://wordpress.org/support/topic/block-anspress-upload-file/

Alex

If you need test next version, please let me know.

Thanks.

Alex

@Daniel,

Should we expect next version recently please? thanks.

Alex

The current issue with multi site blogs (such as in your case where there are a network of blogs) is an error in the install script, and I’m not sure how to resolve it. I hope to have a solution soon but I plan on submitting this to the plugin repository on Monday.

Hello Daniel,

I asked the author of IP-Geo-block(https://wordpress.org/plugins/ip-geo-block/) to help, and he has improved the plugin and upload to github at https://github.com/tokkonopapa/hype-wordpress-plugin, and you might like to update it too.

After I test, it works well in Wordpress 4.8 Multisite, and it would be great if you like write him with the Credit on Hype Wordpress Plugin introduction to show thanks to him.

Here is the screenshot of backend at our wordpress Multisite:

and frontend screenshot:

and here is the email content between us for your reference:


发件人: Kiyozumi Unoura tokkonopapa@yahoo.com
收件人: Alex Lee alexlii@yahoo.com
发送日期: 2017年10月12日, 星期四, 上午 10:39
主题: Re: Help on Hype animation Plugin to be compatible with wordpress Multisite

Hi Alex,

Can your try this one?

Good luck!

K. Unoura by tokkonopapa

On Tuesday, October 10, 2017, 2:11:01 PM GMT+9, Alex Lee alexlii@yahoo.com wrote:

Hello Tokkonopapa,

I find your email address at tokkonopapa

tokkonopapa
tokkonopapa has 25 repositories available. Follow their code on GitHub.

Here is a personal issue need help, and I have to say this is not related to IP-Geo-Block, so I can not post there.

Let me explain what I need if you would like help. You might know Hype animation which is created by two guys from Apple, it is really big contribution to the software world, and here is their official site: Introducing Hype Professional

Introducing Hype Professional
Tumult Hype Professional is the most advanced app for creating stunning animated and interactive HTML5 content. …

and I found there is plugin which support to upload Hype animation to wordpress, but it is really out of update, and I post here to ask Hype official to support: Anyone would help on wordpress Plugin?

Anyone would help on wordpress Plugin?
If anyone can help test, please visit:

Daniel takes the plugin for days work, obviously, it is not compatible with wordpress Multisite yet.

I am not sure this is right way to ask for help, but it would be great if you would like do me a favor to let us know how to make plugin work compatible with Wordpress Multisite, since I know IP-Geo-Block works well in Multisite environment.

Here is the message that show the Error message of that plugin: Tumult Hype Animations Wordpress Plugin

Thanks so much.

Alex

Thanks this is super helpful! We’re busy at the iBooks Author and Hype Conference this week but I’ll merge this change in soon as part of my other updates required for submitting to the Wordpress plugin repository. I’ll definitely credit Tokkonopapa on these updates.

Thanks :slight_smile:

Alex

Hello @Daniel,

It seems there are two ways to embed Hype animation into Wordpress posts: shortcode and DIV codes. I do not know what is the difference between them, and I very care about the speed and performance on Mobile mode, you might like let me know which one is good for Mobile mode speed, thanks.

Alex

This plugin represents the Hype animations with the shortcode – and this (by default) loads the Hype animation as a Div. This is the most performant method. You also have have the option to load the Hype document as an iframe – this will have more of a delay and is only recommended if you have content in the <head> area that you want to use. This method also uses the shortcode method. You can select the ‘iframe’ dropdown in the list of your uploads.

Would be awesome if you could try this out again now that's it's live. The site embeds using the protocol of the current page so it should work within your security settings.

1 Like

Hello @Daniel and @Nacho

I am sorry for my oversight.

I found I can not upload . oam file at backend with hype-wordpress-plugin-master( the latest version which you merged.)
But it works at frontend with the oam files that already uploaded before.

and The version of “hype-wordpress-plugin-short-tag” from tokkonopapa works both frontend and backend.

Here is my test process in wordpress Multisites and some improper information at backend when upload oam files:

1#In order to try to avoid any conflict among plugins, I deactivated all plugins network widely. and only leave hype-wordpress-plugin-master activated in a subsite. the shortcode of any uploaded oam file will be [hypeanimation_anim id=“0”]

there will no uploaded file listed at backend, and the frontend page will be empty if put [hypeanimation_anim id=“0”] in a page.

conclusion: it works for the oam files that already uploaded, but it not works with upload any new oam files.

2# if activate Geo-IP-Block network-widely, the shortcode for any uploaded cam file will be [hypeanimation_anim id=“10500”]

That is all.

Alex

Thanks for this report. Can you do a full reset and delete the plug-in? This will delete all previously uploaded documents.

A lot has been redone since tokkonopapa’s merge so it probably will not smoothly upgrade.

After test, I think it not work with Wp-content-security-policy.

Alex

ok, I will. I tested the above process by uploading and deleteing them only with ftp, should I test to delete and reinstall it at Wordpress dashboard?

If yes, please let me know. Thanks.

Alex

I recommend deactivating then deleting the plug-in from the plug-in page. This will delete the associated database and the hypeanimations folder. Then reinstall from the official plugin repository and let me know what you see.

Once click delete,

click ok, error message show up:

Deletion failed: <? if ( !defined( 'WP_UNINSTALL_PLUGIN' ) ) exit(); global $wpdb; $wpdb->query( "DROP TABLE IF EXISTS {$wpdb->prefix}hypeanimations" ); delete_option( 'hypeanimations_db_version' ); function hyperrmdir($dir) { if (is_dir($dir)) { $objects = scandir($dir); foreach ($objects as $object) { if ($object != "." && $object != "..") { if (filetype($dir."/".$object) == "dir") hyperrmdir($dir."/".$object); else unlink($dir."/".$object); } } reset($objects); rmdir($dir); } } $upload_dir = wp_upload_dir(); $anims_dir=$upload_dir['basedir'].'/hypeanimations/'; hyperrmdir($anims_dir); ?>{“success”:true,“data”:{“delete”:“plugin”,“slug”:“tumult-hype-animations”,“plugin”:“hype-wordpress-plugin-short-tag/hypeanimations.php”,“pluginName”:“Tumult Hype Animations”}}

and the interface shopped as the screenshot:

refresh page, that will disappear.

and then I search Hype plugin, it allow to install, so I installed it from wordpress plugin repository:

after activated it in subsite, but I found the animation data has not be deleted, they are still here:

and it support upload:

and I deactivate it in subsite, and go back to delete again, the error will show up again. actually, I retried several times, that error message will appear everytime.

Alex

Hmm this means that the uninstallation (which should delete the DB entries from your database) did not complete, which might cause problems.

Did the item you uploaded (ID 24) work when you place it on a page?

YES, it works.

Alex