Troubleshooting Timelines & Syntax Error

Hello Tumult team,

I have a similar problem and decided to add it to this thread. I am creating a "one-scene two-layout landing page" website in Hype as my first project. I wanted to have some interaction, such as the testimonial section arrows > click. I created two .png arrows in the testimonial section of the website and on mouse click is supposed to play next timeline where I have some animation happening. It works in preview, but in the browser, it doesn't.

Initially, I tried with a third timeline with a second arrow and animation on the second arrow to trigger the third timeline, so I ended up with 3 testimonials, but it completely confused the software and started bugging out, so I removed it and left only two. But even with only the two timelines, it doesn't work in any of my browsers. I tried Safari, Chrome, and Firefox (the latest versions).

Also, I noticed that I had some issues with the grouping, so I ungrouped the testimonial section, just in case. Not sure if the groups are confusing the software.

On export as HTML 5 with a folder, I get an issue err saying "Syntax error: unexpected token '<' for element: ShowSliderTXT.

The resources were too big to upload in this post, so I added them to my google drive here:

You can see the non-functioning arrows on the site here:

Can someone help me with this?

Thank you in advance.

It looks like your SliderTXT JS function has the incorrect syntax:

<button onclick="document.getElementById('myImage').src=

Just make sure that's valid JavaScript and it should work.

The testimonials section seems to work well for me when viewing the large viewport width scene in 'Untitled Scene 3 Copy'. The right arrow correctly shows the testimonial 2 content and fades out testimonial 1. The first scene's testimonial section doesn't work since the arrow is not linked to anything.

Thank you for the quick response Daniel.

Is there a way to search for the JS incorrect syntax element? I have deleted the part that was supposed to use that, so now I cannot find that custom JS anywhere to remove it.

The animation still doesn't work on my machine.

If you click 'Edit Source' on this JS function in the Resource Library and edit it (or remove the contents) it will work:

Screen Shot 2021-06-30 at 9.36.37 AM

1 Like

Thank you so much, Daniel!! What a great support team! I am excited to use Hype more and more every day.

This solved the issue and now everything works well again :slight_smile:

1 Like

When I am in preview mode, everything works and my commands on mouse click are responsive. Once deployed in the server my webpage loses the responsive animations(on mouse click, on mouseover, etc.) for it. Am I missing something? I export as an HTML5 folder and upload my index file and resources directory to git.

Screen Shot 2021-07-01 at 10.06.20 AM

Hard to tell -- can you post a link to your site? If you'd prefer to email us you can send your document and more info to