Troubleshooting Blank Shortcode for Wordpress Plugin


(Bryan Cowles) #1

I’m trying to upload my OAM file using the Hype Plugin, and once it processes the file is displays this:

Insert the following shortcode where you want to display the animation:
[hypeanimations_anim id=""]

Then, nothing appears in my Hype Animations Manager plugin.


Tumult Hype Animations Wordpress Plugin
#2

What’s the file size of your OAM file? Can you try with a really small one? (A blank Hype document with one small image).

Can you share your login information with me so I can take a look? You can click ‘Message’ on my profile page here: Profile - Daniel - Tumult Forums to send me a private message.


(Bryan Cowles) #3

It is just over 2MB, our wordpress server allows 500MB uploads.

We are hosting the server internally so I won’t be able to give you direct access. I could do a screenshare session?
I’m more in an IT role, so I don’t have access to Hype to make a small OAM. I’ll have to reach out to one of my designers to do so.

Is there a log file I could find to see where its failing?


#4

You can turn on Debug mode in the wp-config.php file for your Wordpress install: https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

This will give you a verbose output at the top of your admin page with any errors. It would be helpful to know what version of Wordpress you’re running, and the version of PHP you’re on.


(Loves Hype) #5

One wild guess is that the folder Hype WordPress Plugin is extracting the .OAM files (these are ZIP-Files in disguise) to isn’t writable. The extracted Hype content resides in the wp_upload_dir()['basedir'] usually this is /wp-content. Hype creates a sub directory there called /hypeanimations/ so /wp-content/hypeanimations/. Inside of there the Hype WordPress plugin extracts the content of the .OAM for later inclusion through the short code. Make sure that the content is actually extracted to exclude this as the source of your error (meaning that the webserver / PHP process has the right to create and manage that folder)…