Timeline breaking inputs on iframe- mobile only

Hi all,
I am using Verge3D and Hype, it seems to work great on desktop, but broken on mobile. The scenario I run into is I have animated a few timelines within 1 scene- these buttons IDs drive the iframe 3D experience. However on mobile they don’t work. IF I remove the timeline and only have the buttons it works. Does anyone have any ideas as to what could cause this?


It’d be best to post a zip of your .hype document along with instructions on how to a success case and instructions on how to reproduce a failure case (like what to do in the document, which mobile device/browser you use, etc.).

A common cause of failure when dealing with IDs is that if you have different responsive layouts, you will need different IDs for the elements on the different layouts, and correspondingly different scripts that address them. However you are saying that the timeline is breaking, which is a bit ambiguous but sounds like that might not be the issue.

1 Like

Thanks Jonathon,
I’m sure you’re right, I am making some assumptions with all of this. Attached is the hype file as well as a link to the project on my site. I believe the preview for this won’t display the interactions of the button ID since they need to be in the same folder I believe- on server.

So the issue is, on desktop (see link below) It works as expected. But if I hit it with my brand new iPadPro, it doesn’t work. I also noticed that if I inspect it in chrome (Desktop), I get the same behavior of it not working, take it out of inspect mode and it works again.

https://jimlangman.com/PC_Test_Bench/index.htmlverge3d_01.hype.zip (49.2 KB)

Thanks for any thoughts you may have on this. I love Hype and I know if I can get this to work with Verge3D- the sky is the limit!


The timelines themselves seem to be working. I don’t see any specific code that drives the Verge3D view, so I think it is probably doing something dynamic to hook into clicks on those buttons?

I can’t test much as I would need the local files for the verge3d view as well, but my guess to try would be to uncheck Use Touch Events in the Document Inspector. Touches on mobile happen before clicks and cancel them out, so I’m guessing that the event that drives the 3d view is not happening.


Jonathan! Thats it! Thanks so much—Fixed it all- you made my day!



Awesome - glad that worked!