The noob and the rollovers


#1

For those that are reading this; we salute you!
I’m making a quick prototype of a quiz for an ungoing contract. I’m in charge of visual and animation, but I still need to put actions on my visual so that our programmer can focus on harder coding. I’m using Flash/Animate and, of course, tumult hype. I was doing good until my rollovers started showing up in the main timeline even though their timelines start with 0 opacity. When I do a preview the rollover shows up with full opacity until I trigger the impact zone which is a circle with 0 opacity.

This problem showed up after a few successful attempt yesterday after which I decided that it was time to relax with the family… now that I’m redoing the whole thing again the problem shows up on first try. What am I doing wrong? Thanks a lot!

(Just to be clear; there’s a circle with 0 opacity that triggers a timeline when the mouse hovers it. This timeline starts with 0 opacity, but shows up with 100 opacity in main timeline and in preview before triggering the circle.)


#2

@dali

A demo demonstrating the problem is the best approach for an accurate solution from the Forum. (Doesn’t have to be the full working file if a NDA is in effect.)


(Jonathan Deutsch) #3

I agree with @JimScott that it would be useful to see a document.

A common area that might be affecting this is the “playhead on/off” behavior with keyframes and how that interacts with multiple timelines. Here are a few things to note:

  • If the playhead is directly “on” a keyframe, only that keyframe’s values will be affected
  • If the playhead is “off” a keyframe (as in, not on top of one), then the values across all timelines, keyframes, and initial values will be offset by the changes made. This includes values like opacity.
  • Alternate timelines in the editor show the initial position of the element based on the playhead position of Main Timeline. This may not accurately represent how the animation is going to be presented.

(Trey Yancy) #4

Set your beginning opacity in the main timeline and then set the opacity keyframes in the other timelines. The same thing applies to other settings. Let’s say you have an object at 100% in the main timeline and in another timeline the opacity is set to 0%. Now change the opacity in the main timeline to 0% and take a look at it in the other timeline. There the opacity reads as -100%. Now try this with the position of an element.This demonstrates the relationship.

Think of it like a staging MacBeth. Arrange your set, the king, and the ghost as you want them to appear when the curtain rises. If the ghost is supposed to be invisible at the beginning, make him invisible.

From this point, use the main timeline to animate MacBeth and another timeline to control the visibility of the ghost so that he fades in as desired.


#5

Thanks a lot for your answers!! I have resolve the problem using TYancys’ approach. I didn’t set the opacity in the main timeline and that’s what was causing me trouble. I will make sure to share a document for you guys to look at next time. Thanks a lot!! :smiley: