Text boxes driving me mad!


(Joe Gillespie) #1

I’ve been spending the last two hour trying to edit a text box. I can’t select the text in the box. It is not locked and the blue frame round it is selectable and resizable. I tried adding a new text box. It initially has the text ‘New Text’ but as soon as I touch the box, that text disappears. The inner HTML says ‘New Text’ but nothing I do will let me select that text to edit or style it, however, it seems to have picked-up the font, colour and alignment from somewhere. If I add another text box, it inserts the box at the top of the page, the text ‘New Text’ somewhere down at the bottom, and in the process, moves the other elements on the page elsewhere. What’s going on?


#2

Hi Joe!

Would You post an example Hype document that is exhibiting this behavior?

What You are describing is unusual - sometimes the box can be difficult to select - but your issue is clearly more than just that.


(Mark Hunte) #3

As well as posting an example as @JimScott says, what happens in a completely new document?


(Joe Gillespie) #4

Thanks for your help folks. The files is over 19Meg so I won’t post it but I think I know what the problem is, I just don’t know how to fix it.

At Jim’s suggestion, I copy and pasted nine grouped scenes into a single timeline. They play alright right up to the last group and this is where the problematic text box is.

I have copied and pasted the last group into a new file. It works just fine and the text box is editable.

Throughout the animation, I have several full screen background images at 1920 x 1280. I have been making these backgrounds visible or invisible using opacity, they fade-in and then out again. Although they are invisible, they are, apparently, present for the entire length of the timeline, so one or more of these earlier large invisible images is physically on top of the problematic text box. That’s why I can’t select the text, even though I can move the entire box. If I bring the text box to the front, it is only at the front in that group. It is still behind an invisible background image in another group.

I don’t know how to solve this. Any ideas?

I know, I should have done something simpler as a first project :?(


(Mark Hunte) #5

Way 1,
Just select the image in the elements list and click the eye icon.
This will hide itphysically on the scene and you then should be able to click the text box easier.

Way 2,
Does not always work. Click the text box once in the Elements list, It will be selected on the scene. Then d/click the Element on the scene.


(Greg) #6

Sometimes I have similar issues with text boxes, especially when I paste text and then edit it (change fonts, padding, spacing etc.). I tried many solutions but most often I end up deleting the troublesome text box and creating a new one.

I really like Hype and have been using it for work a lot but I have to say that working with text and text boxes sometimes also drives me mad. I often find that, when I lock the text box (thinking it’s finished and I won’t need to work on it anymore) and then unlock it and start editing again, I’m often unable to change spacing (it says ‘multiple’ and adjusting the slider doesn’t do anything) and changing padding makes the text disappear.

Anyway, see if the tex box is not locked, change the view mode (from 100% to more or less), try selecting it and copying it to see if the copied box is also troublesome.

Good Luck!


(Mark Hunte) #7

@grzesiek.rogala

If you run into formating problems it may be where you have copied and pasted text. When you do this you may be pasting html markup with styling settings also. Look in the innerHTML and check there when you are having issues with format. If you do see html mark up then you will need to remove it and put in plain text.


(Greg) #8

Is there any way to clear the text I’m pasting from any formatting and just paste plain text? Maybe there is a text editor which clears text of formatting?


(Joe Gillespie) #9

Any text editor will clear text formatting - Text Edit, BBEdit. If you copy and paste into and then back from a plain text editor, there will be no formatting baggage.


(Mark Hunte) #10

I run a shell script/Applescript on the clipboard which Can be used to get plain text and I will detail below.
But the best way is to open the innerHTML editor of the elemnent and past the text in there. Doing by selection of the text outside of the editor will most likely result in formated text being pasted.


My plain texter

Open a new Script Editor.app (/Applications/Utilities/Script Editor.app) document and paste this

do shell script "pbpaste | open -f"


Save the file as shown.


Now open Script Editor’s preferences
Tick the Show Script Menu in Menu Bar


Go to the Script Menu in the Menu bar and select to open the Users Script Folder.


The Script Folder should now be displayed in the finder.
Move the script file you save to it.

Now when you have copied formated text to the clipboard got the the Script Menu and Select the Get plain text… item.

A temp Text edit document will open with the plain text in.


(Joe Gillespie) #11

I have noticed that plain text pasted into the InnerHTML still picks-up styling from somewhere even though it is not specifically specified. I have been using Palatino throughout my animation and when I look at the innerHTML of my problem text box, it is just plain text with no styling, but visibly, it is in Palatino even though Palatino is not specified. Is there a global stylesheet somewhere?


(Jonathan Deutsch) #12

Aside from @MarkHunte’s suggestions, you can also use and animate the Display property to “hidden.” At the times it is not visible it will not count for the clicks.

When editing a text field (not the inner HTML), I recommend generally always using Edit > Paste and Match Style. Honestly I think this should be the macOS default for pasting…

Technically there is a global stylesheet, but it uses Helvetica as the default font for Hype Elements, so the Palantino is probably coming from some other place in your document. You may also want to inspect the Inner HTML of the element and see what that is set to. The Paste and Match Style is probably the way to go to avoid this problem, I would guess.