Text becomes a black background when copying and pasting text


(Giovanni) #1

Hello there,
I’m working on this presentation but the text became with a black background…
I have cut and copy a portion of text and now it is so. Now I am not able to clear it!
Where can I search to eliminate this effect?
Thanks


(Pete) #2

03%20PM

Double click the Text Element, when you see the pencil click on it see if theres anything in the text widget thats unusual other than the text itself.


(Jonathan Deutsch) #3

Hype uses WebKit’s copy/pasting, which unfortunately can add some background styles that may need to be cleared using @petester’s suggestion to Edit Element’s Inner HTML . (We do want to do some filtering to help with this).

Typically I recommend using Edit > Paste and Match Style (command-option-shift-v) which will keep everything in a singular style and won’t add background colors.


(Giovanni) #4

Thank you to all!


(Ken Heins) #5

I have to edit the inner element HTML on pasted text frequently. Or paste it into Text Edit and then back, but that doesnt always work.


(Loves Hype) #6

Paste it into a Texteditor that doesn’t retain styles (sublime, textmate, Atom etc.). If you don’t want to install new software… you can set TextEdit to plain text (look into the menus) and then it also should work with that Software.

Some programms have the “paste without style” option. Maybe Hype could introduce that in a future version (can’t recall of the top of my head if it’s in the beta, I am on the road).


(Freelancer) #7

giovani esistono dei software text cleaner o simili ma dovresti risolvere come ti hanno indicato gli altri.


(Mark Hunte) #8

I run this

get plain text from clipboard.scpt.zip (1.1 KB)

Applescript from the script Menu.

do shell script “pbpaste | open -f”

Open User Script Folder

and place the .scpt file in it.

The Script should now show in the menu.

Copy any text and run the Script from the menu.
A new Temp text document will open with your plain text which you can then copy and paste into Hype. You can close the txt doc and it will be deleted when user tmp items are normally purged by the system.


**Update see below posts **…


(Loves Hype) #9

I just saw that Hype actually supports pasting with matching format (see edit menu).
Also the shortcut Option+Shift+Command+V instead of Command+V should do the trick!

EDIT
Jonathan already suggested it. I should read the whole thread not only the latest posts. :open_mouth:


(Mark Hunte) #10

I knew there was a reason I did not use it.
Just tested it and if you paste directly in to the Text element ( not innerHTML edit)
You still get formated text.


(Loves Hype) #11

That’s weird I just tested it and it worked. I prepared the formatting in TextEdit… but maybe there are differences or this matching/ cleaning is somewhat limited


(Mark Hunte) #12

Mmm. I noticed Div and Span tags when I tried it.
But my bad as it seems any method of pasting the plain text in directly give them!
So it does work as far as it goes to remove most of the formatting but not all. The pbpaste > copy > paste does the same.


(Jonathan Deutsch) #13

Paste and Match Style does still paste as HTML code and add tags, but will attempt to match the surrounding styles if there were any. For the purest text, you can Edit the Element’s Inner HTML and paste there - that is a plain text only box as it is for HTML code.


(Giovanni) #14

Ho già risolto. Mi sa però che ho solevato un vespaio :smiley: