Temporarily disable Mouse Over events?


#1

Hi,

I am new to Hype so forgive me my newbie question(s). :grimacing:

I created a little interactive menu that has some animation at the beginning to build up the scene:

http://temp.pheraph.net/aktionen.html

Each cloud triggers an animation that reveals the underlying lightning bolt. So far so good. The problem is: If you hover over the scene while it still builds up the lightning bolts are shown although the clouds are still invisible. Can I somehow disable the Mouse Over events until the scene is completely built up?


#2

A simply way might be to add an invisible element (rectangle) above all of the elements with mouse over events. Then, when the scene is ready, simply shrink/move the rectangle off the screen.


#3

Easy workaround. Thanks, that did the trick.