Symbols and Multiple Timelines - animation get "randomly" stuck


(www.360FUN.net) #1

Hi,

I’m having a problem with multiple timelines inside a symbol: basically if I start the second Timeline with an Action inside the Symbol, “sometimes” the animation get stuck! “Sometimes” means that you need to refresh the browser to get the error, or you can get it immediately…is really random. :cold_sweat:

Anyway, I found also a workaround: if I start the Timeline with a Symbol Action from the parent Timeline, it always works! :flushed:

So, I will attach a demo with both ways, so you can refresh the browser and see the problem immediately when the right circle get stuck.

I hope you can fix this problem soon because I’m developing a pretty complex project with symbols inside symbols and multiple timelines: using the second way won’t allow me to organise it in the proper way…

Thanks!!! :smile:

Symbol:Multiple Timeline Bug Demo.hype.zip (15.5 KB)


#2

no demo?

D


(www.360FUN.net) #3

Now the download link appeared! :wink:


#4

it worked! you can delete the DB link :wink:

D


(www.360FUN.net) #5

Perfect, waiting your feedback! :slight_smile:


#6

Hi @Cescomare

I can reproduce what you are doing. After some experimenting I can narrow it down to the action that is set to play the “anim” timeline. If you move this action a few frames to the left it always freezes if you move it a few frames to the right it always continues. So when it is at frame 30 (1 sec) it seems to continue sometimes or freeze sometimes. It’s like it cannot figure out what it’s supposed to do. :smile:

So, bug? i guess. Hopefully somebody else will have a little more insight into this. It seems linked to relative timelines.

Sorry I can’t be much more help but I can definitely reproduce this.

D

Here is another document I’ve made that seems to reproduce the same result randomly.
possibleTimelineBug.hype.zip (14.3 KB)


(www.360FUN.net) #7

Great, so I’m not crazy :stuck_out_tongue: Let’s wait some Support Member to get more infos! :smile:


#8

I have the same issue:

http://dynamicsights.com/hype/serviceanim.html

Do it slowly, and it works perfectly. Do it faster, and it gets stuck. I am guessing there is a conflict in the timeline calls…


(www.360FUN.net) #9

I think the best workaround is make the call from the parent timeline, so you’re free to use your preferred speed! :wink:

Any member of the Support Team reply on this?


#10

I’m seeing different behavior if you preview while currently editing the symbol. The timeline action does fire (confirmed from a console.log on that timeline) but something about the animation doesn’t work. When you have exited the symbol, the behavior is correct.

With this file: possibleTimelineBug.hype.zip (12.1 KB), try previewing while the Symbol is open.

I’m also seeing this on your project, @Cescomare

I’m seeing the same issue in your document: http://cl.ly/17022M111s2z

My workaround for the moment is to shift your timeline action to 1 frame after animations complete, and to close symbols before preview & export. I did the 1 frame shift in this file: Symbol-Multiple Timeline Bug Demo-timeline-action-shift.hype.zip (20.8 KB)

This issue appears to be fixed in the next update (coming soon).


(www.360FUN.net) #11

Awesome :grin: waiting for the update so! :relaxed:

Thanks for the help!


#12

Are you seeing that this issue is fixed for you @Cescomare now that Hype 3.5 is out?


(www.360FUN.net) #13

Oh, yeah!!! :smiley: So happy to have contributed to its release!!! If you need other help for the next release, let me know!!! :smile: