Swipe on Scene blocks some click actions


(David Guillermo Escalante Trinidad) #1

When I enable swipe right / left on the scene, this prevent the Select elements to detect click functions on smartphones, even in the “developer tools” view in Chrome.

Not sure if a bug or if I am doing something wrong.

Here is the hype file:

Here the live version (smartphones only)
http://davidescalante.businesscatalyst.com/public_storage/franies_debug/


#2

Hi David!

On a trial run through w/random clicking - no issues.

iPad4 - iOS 10.3.1

Though this is not a smartphone - it still is mobile. I haven’t had time to check my iPhone.


(David Guillermo Escalante Trinidad) #3

You can test this same bug with the responsive view of both Safari and Chrome:


(Mark Hunte) #4

It may be best to post a project that you are having the issue with so we can see whats going on better. Just giving a link to a site does not always help drill down into the issue.

I know this may be hard with the site you are working on but maybe a cut down version.

Also I think there is a similar problem to this post going on…

since it seems only to be the select option buttons that do not work.

I did place a onclick=“focus()” inside which allowed me to click and then hit the enter key ( Using Chrome - Dev tools) to get the selection options to work. Buts as I say we would need to see the project…


#5

I had a similar problem in a project of mine. I was using some external libraries for creating some swipable/draggable content (like carousels, tabs or draggable pictures). Using both (external library and Hype’s native swipe action) killed every other klick on the respective scene. I ended up by deciding either to use the native Hype swipe OR th external stuff in the respective scene… Don’t know if this would apply to your project…

EDIT: oh yes, the reason why I ended up like that is – you CAN use a lot of external libraries with Hype (and you can do a lot of amazing things on that way) BUT if you are running in trouble, it is almost impossible to debug the things :sunglasses:


(David Guillermo Escalante Trinidad) #6

Oh, but I shared the hype file and a live version of the site.


#7

Forgive Mark … I think he forgot his glasses. Normally we are looking at a one line link with .hype in it not a great big Dropbox box :smiley: :smiley:


(David Guillermo Escalante Trinidad) #8

Yeah, I know, the guy its a badass.


(Mark Hunte) #9

Sorry @DBear got that exactly right. I was looking for a link line and did not see the wood for the trees…


(Mark Hunte) #10

It does appear to be a similar issue to what I mentioned earlier.
The swipe action is affecting the click action on the same scene. Not found a fix yet but I can also reproduce it in a clean project without any extra libraries.


(Trey Yancy) #11

The caveman approach is to use transparent objects that don’t cover the buttons. These can vary by scene to accommodate interactive objects that vary by position.


(Mark Hunte) #12

Sorry Trey, what ?


#13

Not sure Trey is on the right page … maybe not even in the right book :smiley:
Clocks ticking on the solution :smiley: it’s a doozy.

I did notice some Verbose logging that mentions:

[Violation] Added non-passive event listener to a scroll-blocking ‘touchmove’ event. Consider marking event handler as ‘passive’ to make the page more responsive.

Also happens with a ‘touchstart’ event.

Swiping is a tricky one.

Wasn’t there something more on this … here in the forums? Apart from your other post?


(Hans-Gerd Claßen) #14

good hint! any prefentDefault set by the runtime¿

as a simple workaround attach the swipeaction to an element behind the selects (and other elements with attached behaviours) and not to the sceneelement … does this work?


(Mark Hunte) #15

Probably would but this is using the native API, so you can only set them on the Scene.

I think there was but I have not had time to look further into this. But I think the solutions may have been to use none native API. for the swipe ( Not sure )…

I did notice that you can still crtl + click to get the options


(Hans-Gerd Claßen) #16

symbols should work too …workaround.hype.zip (1.2 MB)

all in all in may be a hypeissue in handling events¿!


#17

@h_classen - Working for me - iPad4 :thumbsup:


(Mark Hunte) #18

Nice one, that works well.

Yes I think @Daniel , @jonathan may want to look at this at some point.:smile:


(Trey Yancy) #19

The issue is that the swipe is preventing interaction with other objects? Swipe-able objects being inadvertently moved over interactive objects? Perhaps I misunderstood (but then, it was a 10-hour day with no breaks; I might have been a bit loopy).


(Mark Hunte) #20

The swipe-able object is the scene. So if I understand you right ( I confess I do not think I do ) then place normal element under the form button will not work.

Hans is answer using a symbol to cover the scene is a good fix for this for now which does in effect do this though…