As much as I would also want a goToSceneByIndex
I suspect the issue here is really about the scene names not being named in a useful way.
To me it looks like that should be named
var buttonClicked = element.id // botton id example : 'Animation_3'
hypeDocument.showSceneNamed( buttonClicked, hypeDocument.kSceneTransitionCrossfade, 1.1)
scenes.hype.zip (67.0 KB)