Responsive site won't load on iPad


(Trey Yancy) #1

I have created a single page responsive site and am at the tweaking stage. It displays perfectly on the Mac and on my iPhone but when I try to view it on the iPad it will show the site for a second and then automatically reload. As message appears “A problem occurred with this webpage so it was reloaded.” After watching it load and bail by itself through three attempts I get a blank page that displays the message "A problem repeatedly occurred on “http://ohair.com/_TEST_SITE/index.html”.

I’m not sure where to begin to chase down this problem.

http://ohair.com/_TEST_SITE/index.html


#2

Can you please share your document?


(Trey Yancy) #3

HypeResponsiveSite.zip (2.8 MB)


(Trey Yancy) #4

This is the same project where I’ve been trying to get the smoothscroller to work. Andrew put a lot of work into it, inserted multiple scripts and so-on, but the thing never worked (he may have accidentally uploaded the wrong version or he may not have tested it - either way, he made a big effort to get it to work). What I am uploading is the version without the failed scripts. As soon as I get this sorted, I have eight other pages to add.

After playing with it on my iPhone, I encountered a message “A problem occurred with this webpage so it was reloaded.” It reloaded and I could view it. This site is unviewable on my iPad 3 (iOS 8.3). On the iPad it displays for around a second, tries to reload three times (with this same error message), then simply displays the above text along with the URL.


(Mark Hunte) #5

I am not at my mac at the mo. But the learn more buttons do not work on my 5s iPhone.

It may be a simple case of changing the click to touch up.


(Trey Yancy) #6

Thanks Mark. Buttons not enabled yet.


(Mark Hunte) #7

I tried the site on an old 10.6.8 Mac before I did on the iPhone.

The buttons are enabled??? As you can see I got to here with the first one


(Trey Yancy) #8

Enabled in the default layout but not in the other layouts. A few minutes ago I went ahead and enabled the buttons in the other layouts but the pages they link to only use the default layout. I want to sort out the home page first, then base everything else on that.


(Mark Hunte) #9

Are you using on click or touch up.

I found touch up works where sometimes click does not on iOs.


(Trey Yancy) #10

BTW, The black areas have a gradient object touching a black object below. For the 320 and 480 I am using a Hype gradient for the top object but, as there are still a lot of people who are still using IE 9 (which does not display gradients), for the default and 768 versions i used a narrow JPEG gradient and stretched it. This adds to the loading time. I’m wondering if there is a better way….


(Trey Yancy) #11

Much further down the road now. Still encountering failures. Responsive layout.

In order to overcome page load issues. I created a set of Hype docs and placed them inline in Softpress Freeway. They work great in a normal browser but when loading on my iPhone, what does show up is small, left justified, plus it keeps trying to reload, finally displaying the message "A problem repeatedly occurred on “http://info.ohair.com”.

Here’s one of the Hype docs: https://www.hightail.com/download/bXBiYURCZEs3bUM5TE5Vag


(Trey Yancy) #12

Still fighting this darned thing with not being able to load it on iOS.

I have a Freeway page with an inline layout and a stack of Hype docs. They play well as individual items in a Freeway page but as a group I get the “problem repeatedly occurred”. I assume that this may have to do with each item trying to load stuff into the head.

They work fine on my Mac but not on my iPad / iPhone

Here are the URLs:

the whole enchilada:
http://info.ohair.com/index.html

individual items:
http://info.ohair.com/index1.html
http://info.ohair.com/index2.html
http://info.ohair.com/index3.html
http://info.ohair.com/index4.html
http://info.ohair.com/index5.html
http://info.ohair.com/index6.html


(Mark Hunte) #13

What os and iPad and iPhone.

On my iPad Air 2. looks ok.

iPhone 5s not sure its if the look is intentional or not but seems a bit off.


(Trey Yancy) #14

Thanks for your assistance.

I have found the file “http://info.ohair.com/index.html” to be iffy. If I punch it in directly on my iPad4 (iOS 8.3) it works but when I went to it from an absolutely identical link within another Hype object on another page it tries to load but I get the “problem” message.

Go to http://info.ohair.com/questions1.html" and click on the Home item in the menu. This is the identical URL to what I punch in directly, so I’m not sure what is going on.

Just now when I got the message I found that I could select the URL field but instead of a the onscreen keyboard I’m stuck with the default bookmarks interface. I’ll restart the iPad and see if that sorts it out.

I have found that when I add the “questions1” Hype object to the inline layout I always get the “problem” error. It works well on its own. (Well, it did after the first attempt. The first time I tried it the Google Fonts were ignored. reloaded it and the fonts showed up.