Remove directory/nesting/folder for assets


#1

Hi all! Maybe I’m not searching for the correct keywords, but I need to make sure that all assets (including images) are in the same folder and are not nested or separated in different folders. I can’t seem to figure out a way to keep the images in the same folder as the index page when I export… it’s always separated in another folder… default.hyperesources.

Thanks for your help (as always :smile: )


(Jonathan Deutsch) #2

In general the easiest way to do this is to change the line in the exported .html file looking like:

<script type="text/javascript" charset="utf-8" src="test.hyperesources/test_hype_generated_script.js?73957"></script>

to remove the .hyperesources folder so it looks like this:

<script type="text/javascript" charset="utf-8" src="test_hype_generated_script.js?73957"></script>

There are a few contexts where this may not work (sorry off the top of my head I can’t remember them, but it is rare!). If this didn’t do the trick for you there’s two options:

  1. Supported & Automatable: Use an Export Script. These have the ability to define the .hyperesources folder a "." which will export everything in the same folder together.
  2. Unsupported & Not Automatable: Edit the *_hype_generated_script.js file and replace the reference to the .hyperesources folder with a ..

Let me know if you need help with #1 assuming the original tip didn’t work for you. I think there might be an export script floating around somewhere that does this.


#3

Thanks for your help! I figured it out randomly (along with your advice). During advanced export, I checked “inline data file + loader. Then I was able to move my HYPE-584.thin.min.js into the main folder. Then I edited the code manually (the html file) and removed the name of the export folder at h=”…" with a simple point/dot like this: .

This is the line of code:

c}var h=".",c="Default",e="default_hype_container";if(false==!1)try{for(var f=document.getElementsByTagName("script"),

After this, I moved in my images. Seems to work on Safari and Chrome, as well as ipad and iphone using MAMP.


Banners Without .hyperesources Folder