Problems with Zoom in iOS Safari

I have some text boxes but whenever I click on them in the browser, it automatically zooms in and tries to center it. How can I avoid this?

Generally a single click doesn't zoom on iOS, but a double click does? It might be useful to see a zip of your .hype document along with a video showing this in action and any other steps needed to reproduce.

That said, it is likely the answer you're looking for is to uncheck Allow user scaling in the Mobile Options section of the Document Inspector.