Problems with uploading retina @2x.jpg via Cyberduck - problem being the @ in a file name


(peter jorgensen) #1

Hi there.

I’m a datajournalist working at Politiken, a danish daily. We’ve played around with Hype now for 7 months and we’ve published a good deal of the content on our website politiken.dk.

One recurring problem is Hype’s naming of retina files. At least I think that’s the problem.

We use an amazon s3 server for hosting and Cyberduck for uploading, but whenever Hype automatically generates retina versions, the Cyberduck upload fails. If I remove the retina files from the ressources folder and try again - that works fine.

Every time:

Our developer here is pretty certain that it’s a matter of the file name. Cyberduck doesn’t like the ‘@’ in a file name, and that seems like a fair assumption considering everything works smoothly, when I remove the retina @2x.jpg-files from the folder.

I’ve just searched this site for others with the same problem, but the only one that comes close is this one:

Here it is advised to use Cyberduck and no one names a problem like mine.

But it’s a pretty big deal for us. A lot of our content doesn’t work properly on retina devices, because no matter how big the size of my jpg’s for instance - Hype resizes them and makes a @2x.jpg-version for the retina. And with a ‘@’ in the name - I can’t upload them via Cyberduck.

Please help us if you can.
All the best from Copenhagen
Peter


#2

I just did a quick test and I haven’t been able to hit this issue. Can you double check that your computer’s clock is correct and that you have the latest version of Cyberduck? (4.7.3 is the latest right now).

Another client that can upload to Amazon S3 is Transmit – they have a free trial available.

From some searching I haven’t been able to discover what might be causing this.

(My test: https://s3.amazonaws.com/tumult-test/test1.html, which successfully uploaded https://s3.amazonaws.com/tumult-test/test1.hyperesources/ipad%20mini%402x.jpg)


(Daniel) #3

I am having this problem as well. We are using the CMS Cascade by HannonHill and it will not let us upload any file with the @ symbol. It generates an error saying it is an offending character. Because of this, no images are showing up on Retina devices.

I have tried removing the @ symbol on the files names and doing a search and replace in the .plist file to update the names, but it doesn’t seem to work. Are the @2x names referenced anywhere else in the resources folder?

I would love a way to use another character other than @ or to turn off Retina resolution sized photos and use the same ones for every instance.


#4

From one Daniel to another, I’m sorry you’re hitting this issue. To avoid it, you’re going to need to select your images, and uncheck ‘automatically optimize when exporting’ or host elsewhere until our latest update is released–this issue will be fixed in the next update. We’ll be exporting without the @ symbol.

I’m not certain that find-replace will make all the required changes to account for the @ symbol in the JavaScript – @jonathan can clarify that.


(Daniel) #5

Thanks for the quick response and short term fix and for working on a permanent fix.


#6

The latest update (3.5.1) now exports 2x images as filename_2x.png

Let me know if anyone continues to hit this issue with Cyberduck.