Problem trying to upload banners to Campaign Manager

Hi, I was told to update some HTML5 banner ads we are using and were done in Hype v3. So I did update and export them, but when my colleague tries to use them in Campaign Manager, they get an error:
"The primary asset you tried to upload is not rich media, but this is a rich media creative. Please upload a rich media asset".
So, as I'm not a user of Campaign Manager I have no idea of what the problem is, or what to do to fix it. I downloaded again the exporting script for Campaign Manager on the site, but they get the same error again. Anyone can please shed some light on this?
I tried to attach my export but it is too big (4 MB) so I sent it to WeTransfer to share it, hope it is OK.

It is a little hard to say without knowing all the setup, but taking a glance at the documentation:


Rich media creatives:

  • Use Studio's Enabler to trigger exit events instead of click tags

The "DoubleClick Campaign Manager" export script uses click tags, so this may be the root of the issue. To use the Studio Enabler, instead try exporting with the "DoubleClick Studio" export script found on the export scripts page.

Please let me know if that helps!

1 Like

Hello! Thanks for the idea. However, we keep having the same error :frowning:

The Enabler library is required for all rich media creatives.

so isn't this the page for the right setup ... ¿

*never made an ad myself though :innocent: so it's just a guess :slight_smile:

Thank you @h_classen, but it didn't work. At this point we're at a loss here!

Hmm.... Do you have an example of a banner that uploads correctly that we can compare this too?

One thing you might want to do is run your resources through Imageoptim -- this will shrink down all your images and SVGs so file sizes are smaller. Some ad networks flag SVG files for weird code (there's code in SVG files that can execute malware) so this will also standardize the SVGs you have.

Hi @Daniel, thank you for your comment :slight_smile: Unfortunately, we don't have any recent creative since we haven't been active making html5 ads. Something may have changed in that time, so I re-downloaded the export scripts and since it didn't work I turned out to the community in case something happened that I needed to be aware.

My colleagues are also looking into it, but so far we haven't found what is failing besides that error message they get.

so you followed those instructions and it did not work¿

Yeah, I put the enabler line inside the HTML head tags and exported the ads as HTML5 using the DCM export since the exit is in Double click DCM action. I also tried Double Click Studio exit and script, also Advanced exporting, none of them worked. We will probably use GIF :frowning:

I did a check using, mainly complaining about the size etc.

1 Like

Thank you for sharing that. That tool looks great! I'm not really worried about sizes and all, but I reduced the pictures weight and now I have more alerts than before. But I can see the ad no problems:

Maybe it is something my colleagues are doing wrong in Campaign Manager but that is far away my 'realm' and I really don't know what to check in there.

Can you share your Hype file in here?

(Also, aside from the export issue, its crucial to decrease the file size of the banner as Google Chrome will probably block this due to its heavy ad Interventions) + Publishers might decline the ad as it's too heavy.

I contacted Google Campaign Manager support, and they said:

In this case I'm able to see that this creative has to be uploaded as a Display creative - HTML5

I was able to upload it with no issues

Does that help?

Thank you, I'm passing a screenshot of this comment to my colleague- Really I appreciate your help and support.

Hi thank you so much for asking! If you want to give it a try, I uploaded it here: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
But please do not use this materials anywhere.

After a couple tries, it was impossible for us to get rid of this error, so we resorted to create animated GIF the traditional way.
Anyways, I would like to help you all for your help and comments :slight_smile:

1 Like

Darn - I'm curious if you talked to google support at all? They made it sound like it was just an issue with the initial configuration.

I wish I knew what the problem was to share it with the community because right now, nobody learnt anything with this experience :expressionless: But I was sharing the ads to a colleague that was sending them to a third party and it is complicated to get detailed feedback. I even sent them screenshots fo your replies but nothing worked AFAIK so that's it.

Okay, thanks anyhow!