Preloader get's question mark after loaded / And sharing my site made in Hype

First I want to share my site (my art works), made in hype. It is an ongoing process as new works will emerge in time. www.zantman.be

The only trouble I get is with my preloader. After the html files are loaded and you switch between pages, the preloader turns into a question mark. Like it cannot find the file (preloader.gif). What could be the problem? (And why safari marks my site as unsecure? Because I use google analytics?)

To answer the unsecured question first, it might be because you do not have a SSL certificate or if you do, it might be misconfigured. If you don’t, they can be aquired for free or nearly free.

The other, without a source file of the Hype problem at hand, is hard to say. Looks ok to me, after browsing a few pages, if it’s that green flashy thingy you refer to as preloader.

Only warning I see is that you are still using ‘ApplicationCache’ which is deprecated. I got the feeling I wrote this before…?

On my iPad pro 10,5 there is no question mark to be seen. Only strange thing I encounter is the following screenshot:


This is the first time ever that I’ve seen this message.
I guess it has something to do with the size of your site.

‘ApplicationCache’ It is a setting I need to find (where?). I will turn it of and re export. Thanks

You may have added it there yourself :wink:

<!DOCTYPE html>
<html manifest="index.hyperesources/cache.manifest">
  <head>

Ah I see. I just did some copy and paste.

If I visit the https:// URL of your site it is marked as secure, but most links on the site will eventually take me to the insecure http:// version. You can typically add server-side redirects to make sure visitors always go to the https URL and then additionally I would recommend pointing links to the https URLs as well so your server doesn’t have to do extra work to do the redirect.

This is the Create offline application cache setting in the Document Inspector. Typically you do not ever need to enable this unless you are developing a web application that must be able to run without an internet connection. Further, this web feature is pretty buggy (and now deprecated), so there’s a good chance it could be causing the preloader problem. I couldn’t reproduce it myself, though.

Thanks a lot. I will use now ‘https://’ instead.

The loader will show the question mark irregulary If all the pages are loaded somehow in the cache. If I empty the cache the loader works fine.

1 Like

It looks like the preloader.gif isn’t references in the cache.manifest file, so it isn’t being cached at all. This means when the cached version is loaded on the 2nd time, it won’t retrieve that file. It is probably best to not use the application cache at all.

1 Like

I have been able to fix all the tiny errors. Thanks :slight_smile:
My site runs even more smooth now.
https://www.zantman.be

1 Like