Physics will only start when it is in the first scene - not in any other scenes..?

Hey there guys.

I simply cannot understand why a physics scene will act out its magic if it’s the first scene, but not if it’s let’s say the fourth. Ot any but the first.

I tried to pause the timeline, but that won’t do the trick either.

I’ve attached my file. If anyone would give it a look, I’d be grateful. If you drag the behaviour scene up to be the first, it plays in preview. If it’s not the first, it won’t. Why is that???

Hope one of you magicians got the answer.

Best from Copenhagen
Peter
smittefaktor-physics-question.hype.zip (498.3 KB)

This is a bug. It looks like it is caused by there being a timeline action after the “jump to scene” timeline action.

The workaround for your case would be to remove the later timeline action, since it won’t ever be called anyways.

This has been filed and we will investigate further for a fix. Thank you for reporting this and sorry for the trouble it caused!

1 Like

Thank You for this info - I’m surprised I have not run across this bug over the years.

@politiken

Below is a screen shot of the “extended” timeline - that is the timeline properties that extended beyond the “Jump to Next Scene” timeline action… i.e. “Group” > “tekster”.

I removed this “extended” timeline section for each scene and the final scene worked as intended.

Until Jonathan’s post above I could not understand why this solved the issue.

2 Likes

It surprised me too, but I did a test and this is found to be new to v4, and probably a rare case to run something after a timeline jump.

Thanks guys. You were off course spot on. The later timeline actions were obsolete anyway. Just there from a previous version, so it’s all good now.

Thank you for taking your time to look into it for me.

Best from Copenhagen
Peter

3 Likes