Photics-Physics-Bridge – Name The Function

What do you prefer as the name of the Photics-Physics-Bridge for Tumult Hype?

  • PhoticsPhysicsBridge
  • PhPhB
  • mjs
  • ppb
  • hypePhysics

0 voters

Right now, the “Photics-Physics-Bridge” is named after Matter.js

function mjsVelocity (e, xSpeed, ySpeed) {
    Matter.Body.setVelocity(hypeDocument.getElementProperty(hypeDocument.getElementById( e.id ), "physics-body"), {x: xSpeed, y: ySpeed});
    }

Yet, I hesitate to call it that, as it’s not exactly Matter.js — It’s shorthand between Hype and Matter.js. What would you prefer to call it?

____Velocity

Too short, it might collide with something else. Too long, it’s too confusing and longer to type.

Alternatively…

Do You Like The Idea of the Photics-Physics-Bridge?

  • Yes, it’s totally necessary.
  • Nah, I don’t need it.

0 voters

Hmm… not much insight with this poll. It’s surprisingly split.

I didn’t want to call it ppb because it didn’t sound cool enough, but the corona virus pandemic introduced me to a new acronym… PPE.

If that’s good enough for professionals, such as doctors and firemen, then it’s good enough for me!

So, here’s the naming convention…

ppbVelocity(e, xSpeed, ySpeed);

I think that’s easier to type than what’s done with Hype. For a while, I was wondering why I would even bother with this. Heh, then I looked at my notes and saw the word — RADIANS! :laughing:

It’s totally needed.