Oh, Snap! Snapping not going away

When I’m tracing out a shape I keep getting snapping popping up wanting me to align my point with other existing points. I have it turned off under ‘Arrange’ and yet it persists. This even occurs when I’m adjusting the handles. Very annoying. How do I rid myself of the pesky guide?

I should add that it seems like the vectors are on a grid and the points jump to grid coordinates. When I use the up and down arrows to adjust a point they just a few pixels, so there is no way to make finer adjustments.

Using the command-key when setting the points should solve your problem…

Vector Shape points presently must be on pixel coordinates; at a higher zoom factor this would make them appear as if they are snapping but it is more a factor that they aren’t being placed on fractional pixel values.