Mobile > Can't scroll on swipe element

Hey Guys,

i created a swipeable (left/right) image gallery via timeline. On swipe, the timeline continues. Works fine.

When i come to that element on my mobile device and try to scroll down further - it doesn’t work. You can online swipe left/right on that element, scrolling down further is not possible.

This is a problem since that element is pretty high an the user won’t be able to scroll down further.

I hope you guys understand what I’m trying to describe.

Thanks in advance!

Can you share a Hype document and a link? It might be that you have scaling set to 100% on the height dimension and this is cutting off your Hype content.

Okay, I’ve created a simple example. There are five sections. Section 3 is a gallery that you can swipe right and left.

Because section 3 is higher than the viewport, you cannot scroll to section 4 and 5 in the mobile version.
I suppose it is due to the functionality of being able to swipe left and right.

I hope you can help me, because this is a big problem for me.

Here’s the example link

Thanks in advance! (52.4 KB) (38.9 KB)

no easy attempt, just a playground, not well tested … if you like to use it … i’d explain a bit :slight_smile:



I’ve used a different approach from Hans’ using just the Hype interface and it works well on my iPad. I’ve used a Symbol which allows its own swipe action. (23.8 KB)

Starting with your Demo Hype document…

  1. Converted “3” group (folder) into a Symbol (“Symbol 1”).

  2. Set the “3” folder - which is now inside “Symbol 1” - to 2000px wide. This width will accommodate 2 “slides” @ 1000px each in width. If You had 10 slides (1000px width) then the width for the “3” folder would be 10,000px.

  3. A “pause” action on the Symbol’s Main Timeline for each slide duration. In my demo the slide moves 1000px (the width of the slide) for my chosen duration of 1 second.

  4. “Symbol 1” has the “Swipe Left/Right” actions set to continue the Symbol’s “Main Timeline” forward or reverse as appropriate.

This description reads longer than the actual work involved in the set-up which goes very quickly in practice.


works great :slight_smile: :+1:

1 Like

@JimScott That worked! So far I always used the Actions Inspector instead of the Symbol Inspector to perform actions, this was obviously wrong. Thanks a lot!

@h_classen Thank you very much as well! One more question for you: In my file, the mobile version doesn’t scale to 100% width. How can I adjust that?

Thank you guys!

1 Like

not sure what you mean …

to be responsive you’ve got to turn on the scale 100% checkbox in the sceneinspector.
elements responsiveness is handled separate in the elementsinspector …