Missing font(s) in UI


(Michael Prewitt) #1

There are a couple fonts missing in the UI when I run Hype 3.5.3. The time counter was there, and is there when I restart, but went away while using the app. The other seems to be permanently missing. The app gives no errors, so I’m not sure what the missing font(s) are.


#2

Hi Michael!

Some one else recently reported the exact problem to what You are showing above in your post. @jonathan responded with a suggested fix, to which there was no follow-up by the OP.


(Michael Prewitt) #3

I tried the ‘Restore Standard Fonts…’ command. No change, app still shows “?” characters.

I also verified that Helvetica Neue Light is installed and enabled.

I also have Helvetica Neue LT Std (same font family from a different source), in many weights including light. I tried disabling that to see if there was a conflict, but it didn’t help.


(Michael Prewitt) #4

Which is to say that @jonathan’s suggested fix did not work for me.


(Jonathan Deutsch) #5

It is odd that disabling the other Helvetica Neue fonts did not help; did you try restarting Hype after this? I can definitely say the issue comes from the font configuration on your machine, so about the best I can advise is to try removing/replacing those fonts. Both of those views use Helvetica Neue Light. There is fallback code if the font is not found to simply use the System font, however in this case the font is found but returning incorrect character data so there’s not much we can do to prevent this.


(Michael Prewitt) #6

I tried restarting Hype, it makes no difference. It’s odd that the time code displays on startup, but not the text in the top right, since as you said they are both Helvetica Neue Light.


(Steve) #7

Good News! The issue is NOT present in the upcoming Sierra Mac OS version.

No changes in fonts on my end but running the GM version of Sierra and Hype works well with no display issues regardless of viewport size.