Make "Automatically optimize when exporting" stay off

  1. What do you want to see in Hype?

Make "Automatically optimize when exporting" stay off.

  1. Have you found a workaround for this problem?

No, I am checking off the box every time I import a new image file.

[X] Nice to Have
[ ] Important
[ ] Can't use Hype without it

1 Like

not tested:

defaults write com.tumult.Hype4 newResourcesAreSetToAutoResize -bool NO


Also, document in Hype Cookbook with additional commands that might come in handy:


Thanks for the request!

Beyond the defaults command mentioned, do note that you can multiple select images in the Resources Library and turn them all off.

Out of curiosity, is this something you'd like at the document level (some documents you do want to have optimize turned on) or at the application level where under no circumstance do you want it?


As I create banner ads the exported product have to meet required data file sizes. For example 150 kB. I have to be very exact when compressing all resources. For this I use Pngyu, Svgomg, Imageoptim, etc.

I always turn off "Automatically optimize when exporting". For me it would be best to disable this in the application settings.

1 Like

Cool - thanks for elaborating on this.