Link in iOS app not working any more


#1

Hi,

strange things happen sometimes. For some reason the links to the App Store I have in some of my apps (https://itunes etc…), don’t work anymore. I don’t know when this has happened, but I noticed it when I was busy updating an app from 2 years ago. This was made the " @nick way". The update has been made with the timesaving “wrapping” app by @Photics. Does anyone have a clue? Did Apple change the rules, or do I need an extra line of code in Xcode?


(Mark Hunte) #2

How are you links made and opened??


#3

Like this:
https://itunes.apple.com/us/app/romeinse-cijfers-ivxlcdm/id1116400243?l=nl&ls=1&mt=8
I also tried the “itms” thing, but that doesn’t work either
Maybe forgot to say that they can’t be opened from within the app.


(Mark Hunte) #4

Sorry maybe my misunderstanding…

But I mean in the Hype project. how are you doing the links.
i.e code or button with actions and what actions…


#5

49


(Mark Hunte) #6

Does it work from running in xcode directly on your device and or simulator


#7

No, it doesn’t


(Mark Hunte) #8

Ok if you connect via cable to you device and run the app from xcode on it.
You can then open safari on the desktop and use the developer menu to select your connected device and the running apps webpage.

When tapping the link are any errors generated

You can also use the target button in safari desktop elements inspector.
Click the target button. Then tap you button.

This will show you what you are actually tapping in the element inspector ( desktop)


#9

there’s no iPad in my dev. menu in Safari. only iMac.


(Mark Hunte) #10

You have to run & build the app from Xcode to you iPad when linked via cable.
Once the App is launched on the iPad you then go to the menu and it should be listed.

If not , I think you need to allow it… let me check what the settings is as I do not remember of hand.


(Mark Hunte) #11

On The iPad

To Enable Safari Web Inspector on your iOS device**

  1. Open the “Settings” app on your iOS device.
  2. Navigate to “Safari > Advanced”.
  3. Turn on the " Web Inspector " toggle.

#12

yes that works.


#13

No mistakes generated. When I try to use the link from Safari on the iMac, it works. But not from the iPad. It looks like the link is blocked, thus no mistake is generated I think. Other local links in the app are working.


(Mark Hunte) #14

Not sure what you mean by local. But if you change the link to a non apple or a some other link with http and not https does it work…


#15

Local: the links in the app to other scenes etc.
http non apple makes no difference.


(Mark Hunte) #16

Just testing here now I am at my Mac.

Links to other sites work. Including Apple.

But not that type link. Did it open the App Store App or go to a webpage.

I am wondering if we should be seeing a popup saying

[ cancel| open]


#17

I tried again on the mac. Message from Safari:
cannot open itms-appss://itunes…
There is one s too many I think?

But before it did go to webpage of Apple

no popup

57


(Mark Hunte) #18

Thats an old protocol


#19

Yes, but something is changing the address, from https to itms


(Mark Hunte) #20

I get the impression that you have to use the https: but the the browser is trying to push it to the iOS AppStore app.

If open this page and I click the link above via my iPhone that what it tries to do. And I get a message alert
to open in AppStore [cancel|open]