Issue with color in Ellipse


Please check the screenshot to understand what I mean:

Here is project file: (843.2 KB)

I updated Hype today to Version 4.1.14 (754) Professional Edition

Should I rollback to previous version? if Yes, how please?


Hello @jonathan @Daniel ,

Did you have a chance to check the attached document?


Hi alexii!

Unless I have completely missed something - your uploaded project file ("xxx.hype") does not bear any resemblance to the screen shot in your original post.

Screenshot > "xxx.hype" upload

Like @JimScott said, it'd be great if you could attach the reproduction document.

I'd be curious:

  • are there some settings you have on the group that might interfere with the display - visibility and display are the obvious ones, but perhaps a transform or filter effect might cause rendering issues
  • if you close/re-open the document does it appear?
  • Did it ever have a fill color and did you perform some steps where it then vanished? (looks like you might have duplicated?)

Hello @JimScott @jonathan ,

Sorry for uploaded a wrong file, and here is the right one: (92.2 KB)

1 Like

@jonathan was on it re: transform being an issue...

Don't have enough time right now for a complete answer, but the main issue is all groups but the "red" group, have been rotated ("G" & "Y" also do not show the white ellipse "Ellipse 1" in each group). When I set these other groups ("B", "Y", "G") to a rotation of zero they display as expected.

Maybe this will be enough for You to go on and fix things to show up as You intend.

1 Like

Thanks for attaching the right file @alexlii and @JimScott thank you for the initial investigation.

This is a Safari/WebKit rendering bug. It does not occur in Chrome or Firefox. I've filed this against the WebKit team here:

I think your options would be to remove the z rotation on the group, remove the overflow as hidden on the group, or to perhaps redo it using an outline instead of a second shape.

Thanks for reporting this. Hopefully WebKit can eventually fix it...:crossed_fingers:t2:

So > some "patches~kluges"...

  1. Turn off "Use WebKit Graphics Acceleration" in the "Document Inspector". Only works for Preview mode, not for the Editing window environment so not particularly useful for detailed work as You are creating things.
  1. Rotate the Z-axis of both circles (white and the color circle) inside the group to at least 22° (21° or less will not do curiously - please see Fig. 1). Since we are dealing with circles the Z rotation does not affect appearances the way it would a triangle shape for instance which would require the manual manipulation of the shapes to get what You want.

Now You can rotate the Z-axis of the group to whatever degrees You wish and things appear as intended.

Strange about that 22° or more being required.

Screen Shot 2023-11-29 at 1.41.18 PM

1 Like

Good point about turning off Use WebKit Graphics acceleration, that should do it too.

Yeah, one thing I wrote in the bug, and also the WebKit screener did a bit more testing on, was that the angle of rotation mattered in reproducing this.

My best guess would be that it might have something to do with a 3D hidden surface removal algorithm that is placing one shape incorrectly above another in the layering. But that's just an unactionable shot in the dark :slight_smile: