Index page not recognized by browser (Firefox)


(Kostas Kiousis) #1

Hello there!

It’s probably not a big deal for a non-novice (unlike me):
I’ve created a test site (one scene - several layouts) in Hype Pro and, after Advanced Export, I ended up with a ‘Default’ folder containing a ‘Default.hyperesources’ and an ‘index.html’ file. I uploaded these two (not the whole ‘Default’ folder) on the server that hosts a site of ours (for testing purposes) and all I got from the browser was a ‘403 Fordidden/nginx’ message.

What am I doing wrong? What is the proper procedure to have my ‘index.html’ page (the one automatically created by Hype upon exporting) to be properly shown?

Thanks for your time and care in advance.
Kostas


#2

If you aren’t able to load a .html file that is on your server you may have some permission issues in the enclosing folder. Are you able to check the CHMOD settings for that file? In an FTP app like Transmit, you can see this by selecting the folder, and it appears like this:

44 AM

Your .html file should have settings like this:

28 AM


(Kostas Kiousis) #3

Daniel, you saved the day!

It was actually as you described it. I had uploaded numerous ‘index.html’ files before (in several tests I run every now and then) and never did I have such an issue, until now, so it never crossed my mind to check the Permissions state.

I’m in your debt. Keep helping people and have a nice (whatever you please)!
kostas