iBooks Widget 'Play automatically on page' problem


(MajorGem) #1

Hi everyone,

I can’t for the life of me get an iBooks widget to PLAY ON PAGE even though the settings are marked as such inside iBooks Author. Heres the crazy thing, when i run the preview on ibooks for Mac the HTML widget WILL play on page but on the iPad it will not. Instead the widget launches full page and plays.

Ive tried setting it to run automatically on page load inside iBooks author but it won’t. Is there anything i can do in hype to fix this or anything i might have done wrong? The hype file runs automatically and requires no user input to start etc


Repeat animation when an iBook widget gets opened more than one time
#2

In my tests, a widget plays in iBooks for Mac after a click, and in iBooks after a tap (without going full screen).

Here’s the setting I used:

If you have those settings enabled and you’re seeing something different, could you attach your widget?
iBooks might be disabling your widget from playing inline if your widget requires a lot of memory (or is very tall or wide).


(Nick ) #3

I just noticed this as well.
I typically though use full page widgets so I have never needed to play one in the page.
Here is my Hype document ( very small) and the ibook document (test.zip)

test.zip (1.0 MB)

testwidget.hype.zip (12.7 KB)


#4

When I set it to play automatically, it does play when I hit the page, but not when I return back to it. It does play again if I go back a few pages, then return (or if I re-open the book)

play-on-ipad-automatically.mp4 (3.5 MB)

Here’s how it works (with tapping, and not set to play automatically). When I first tap the widget on the iPad, the document loads (and plays). If I tap the button, it plays again:

play-on-ipad.mp4 (1.1 MB)

Are you all on the latest version of iOS?


(Nick ) #5

Unfortunately I have not moved my iPad up to the latest iOS that may be the issue.
I’ll update and see if that fixes it.


(MajorGem) #6

Hi both, after about 2 hours of going CRAZY today i think it may be down to the iOS version. I was running the test on an iPad 3 running iOS 7 and it wouldn’t work for love nor money. I then tried it on an iPad Air 1 with iOS 8 (latest build) and it worked fine. Sometimes the simplest solution works, i just wish i hadnt spent two hours searching for it :smile: