iBooks Author Error Importing Widget


(Frank) #1

Hello. I’m trying to import a Hype Widget into iBooks Author and am getting an error…

I’ve gone through and renamed all the resource files so that they do not have any spaces. There isn’t an easy way that I know of to debug the import in iBooks Author to figure out what file is wrong. Can someone look at my project files and help me to narrow this down? Thanks!

Frank


#2

What file formats are being used?


(Frank) #3

Oops. My project and widget files are over 200MB! :upside_down_face:


(Frank) #4

They are as follows…
-mp3
-wav
-m4a
-png
-js
-gif

My first project worked fine. However, going through this for you, I noticed that it didn’t have any .wav files. That may be it??? Urrrr!

Frank


#5

Apple says (BTW these supported file formats may change):

Video and audio requirements

  • You can’t use media that has .m4v or .m4p file extensions. Use one of these formats with an .mp4 file extension:
  • H.264 video: Up to 720p, 60 frames per second. High Profile level 4.2 with AAC-LC audio up to 160 kbps, 48 kHz, stereo audio. Videos that open in iMovie 10 with the HD 720p option use these settings.
  • MPEG-4 video: Up to 2.5 Mbps, 640 x 480 pixels, 30 frames per second. Simple Profile with AAC-LC audio up to 160 kbps per channel, 48kHz, stereo audio.
  • For audio, use AAC (8 to 320 Kbps, 48 kHz stereo) with an .m4a file extension.
  • Video and audio media in HTML widget bundles aren’t DRM-protected.
  • If a movie or audio file doesn’t play in your widget in iBooks Author, preview it on your iPhone, iPad or Mac. This shows how the file will play in your completed book.

So it is likely your wav file…


(Frank) #6

Thanks guys! I’ll make the change and give it a try again.

Frank


(Frank) #7

Alright, so I replaced all .wav files in the project with .m4a audio files. I also reviewed the resource files several times renaming/replacing files that have spaces. I then went to load the widget into iBooks Author and received the same error. Sorry that my project is so large making it difficult to share. I’ve placed the files in Dropbox. They can be found here… https://www.dropbox.com/sh/a8t4w8x9mejf10g/AABzp8BcZsv0xylBB8EEe43Aa?dl=0

Thanks for your help!

Frank


#8

I tried a few things after exporting the .wdgt file (I went into the file structure of the wdgt file to do these things):

  • deleting files with the & character (no change)
  • deleting additional .js and the ‘license’ file which had no file extension
  • re-encoding mp3s (One of them was an mp3 with extended attributes which included a ‘cover photo’ linked to the mp3 file… no change)
  • deleting m4a files (this worked!)

So then I re-encoded all of the m4a files in the Hype file by opening it up, (ctrl + click and then re-encoding all of the m4a files). Then re-exporting the .wdgt.

I used ‘permute’ to do this in a batch, but the problem is likely one of those .m4a files is not being recognized as an m4a file by the creature behind the iBooks Author curtain validating files: https://www.dropbox.com/sh/4kda8lk3iei9tgv/AADZrCy9XJLiFdvs69kuSo6Ja?dl=0


(Frank) #9

Wow! Thank you. I’ll try replacing the m4a files and recreate the widget. Thank you so much!


#10

Check the link— you can download the fixed version.


(Frank) #11

Will do!