I can't save my hype document (Solved)


(Gary Tamblyn) #1

I worked on a document this morning and I thought I saved it earlier in the day. However it appears it didn’t save and basically won’t save at all. it goes through the motions, but nothing appears on the desktop or in a folder I’ve tried my computer’s internal hard drive and an external drive.

I reported an issue via “help” menu and clicked on the ‘send current open file’ button, but that didn’t work either. Basically my document is open, but I don’t think I can save it in any way. Does anyone know of a terminal command that can force a save somehow ?

I’m using Hype 3.6.3 on OS X 10.8
Any advice gladly received.

Thanks
Gary


(𝕄𝕚𝕔𝕙𝕒𝕖𝕝 𝔾𝕒𝕣𝕠𝕗𝕒𝕝𝕠) #2

You could try exporting your project with the recovery file turned on. Then, just rebuild your project from the recovery file.

I think that’s a good first attempt, as you can still leave Hype running.


(Gary Tamblyn) #3

Thanks for your help, I thought that may be the answer, but it doesn’t even export a HTML5 document. :frowning:
It will show up on Safari from the preview option, that seems to be the only way anything will appear outside of Hype.


(Gary Tamblyn) #4

I actually figured out a way to do it.

For some reason Hype had become corrupt and wasn’t allowing saves, however I went into terminal and then opened a simultaneous instance of hype (two hypes running at once). You can do that by typing (making sure you include spaces).

open -n -a

Then a space and open quotes.

Now drag the hype application (from the application folder not the dock) to the terminal window, and a path to the app will appear, something like:-

/Applications/Hype2.app
(weirdly it says Hype2 on my machine, when in fact it’s Hype 3).

Then close the quotes. The final text looks like this on mine:-

open -n -a “/Applications/Hype2.app”

Then press return

Once the new version opens I was hoping to copy and paste the Scenes across, but it seemed to load the document in the new app straight away. From there It saved first time :slight_smile:


(Mark Hunte) #5

Good thinking👍🏽

Maybe worth you looking at the logs and see if there is one for hype crashing with some sort of exception which is most likely since you could open a new instance.
If you find the log maybe send it to the Tumult team @Daniel


(Gary Tamblyn) #6

Couldn’t see any current hype logs in console, just some in a HypeLog.txt from back in 2013. I’m just glad I managed to save the document. It was strange; Hype worked perfectly fine, it just wouldn’t save, or save as template, or export in any way, but the Preview and Hype Reflect worked fine.

Opening the second instance of hype, the un-saveable document was already there and saved from that version perfectly.


#7

Also if you force quit the app with the doc open and then reopen Hype the same windows will be there and you can save from there. Saves going the terminal route. It’s probably that Hype crashed at some point. Mine sometimes doesn’t allow me to save but a popup window says so. This is what I do.