Hype unfocus on Drag Out of stage, can't focus back


(Lucky) #1

Hey guys,
This is an issue we at work have struggled a month with

Issue:
On dragging an element outside of the stage using the control timeline… action I lose all ability to select any of the elements on the stage.

Platform:
iOS 8, iOS9.

Example:

As you can see here there are 3 elements on the stage.
A button which triggers an action on mouse click (I’ve tried, down and up as well).
A web button which goes to a site.
The slider which has an on drag control timeline action.

When you drag the slider outside of the stage the whole stage loses focus andwhen you let go outside of the stage then you start clicking on the buttons none of them work. But the slider still works. As if it has a focus which has been set. However


When you slide it back inside of the stage all of the buttons work again.

This has been pretty frustrating and its an ipad bug i cant solve apart from not using control timeline actions(which i have to do for clients). If i was to make my own custom control timeline action it actually works, but with the built in drag and control timeline it just unfocuses everything apart from the slider on exit of viewport.

@jonathan @Daniel do you have any idea what this could be? I know it’s a very specific bug, but I’m really stuck and I really want to figure it out so that i dont need to use custom JS and any designer on the team can just use the built in control timeline function instead. But this issue occurs on publishing these ads all of the time.

Would really appreciate help with this from anyone who has any idea what couls be causing this.

Thanks!


#2

Can you see if you get different results when unchecking ‘use touch events’ in the Document inspector? There is a related issue with click/tap events which you might be hitting.


(Lucky) #3

Just tried both methods, both ways produce the same result with you not being able to click on anything after you swipe out of the stage


(Lucky) #4

in this zip file i have 3 versions
1 with touch , 1 without touch , 1 custom where i tried to remake your control timeline functionality(poorly)
All 3 work untill you leave the stage with a swipe, when you swipe out dragging the swipe button all the buttons get disabled
Archive.zip (563.4 KB)


(Mark Hunte) #5

All works fine for me on iPad Air 2!

Tested from Hype reflect and from my webspace
swipetouch
swipenotouch
swipecustom


(Lucky) #6

the thing is it could also be on our web enviroment. It goes inside of a container then it goes inside of the paper, which is why i was hoping it was hype itself.