Hype crashing on opening


#1

My Hype document crashes on opening. I was just about to publish some final edits for a site which goes live today nut have been having problems with viewing an attached pdf in browser.

To solve this I updated all of the Pdf’s to zipped Pdf’s. On changing the second URL in the mouse click property the app crashed. Then when I navigated to the contact scene of the site (to update the final URL) the app crashed again.

I thought I’d duplicate the file so I could try playing around with it but Hype crashed on duplication. Now I can’t open the file at all as it immediately crashes.

This site if for a wealth management company who want to show it to clients today. I need a fix for this urgently.


#2

Here’s a video of what happens when the file crashes. I have sent a crash report earlier before the file crashed continually (when it only crashed navigating to the contact page)


#3

#4

Testing another file duplication of a document seems to be the cause of the second issue. I duplicated another document on a different mac and Hype crashes then can’t reopen again.

I’m running the latest Mac OS and version of Hype.


(Rick) #5

I can’t help with the crashing but can’t you go back to a previous version like on your hourly back upped time machine?
Or open Hype->File-> open recent?
Or maybe even relocate some or all source files and try opening the document from inside Hype again?

And in the future, I know it’s donkey balls now, make copies of your Hype document. I learned that the hard way myself…

Hope someone else can chime in.


#6

Hi Rick

Thanks for your input. I don’t have time machine, I normally use version control via Dropbox. Not sure how Hypes auto-save works with this.

I found out that it’s not actually the file itself, it’s an issue with Hype. I opened the file on another Mac no problem, but then if I duplicate the same issue happens; Hype crashes on opening. Then I can’t open Hype again. If I login on the same Mac with a different user I can open the file again.

The problem of moving between scenes causing a crash I worked around by duplicating the scene and deleting the offending one. The issue seemed to then affect another scene, so I followed the same procedure again and can now move between them all.

I thought the days of having to manually save different versions of a file were long gone! :grin:


#7

Please re download Tumult Hype from http://tumult.com/hype/download/ and drag that version to your Applications folder. You are likely hitting an issue which was fixed in OSX 10.8 which was fixed shortly after the update.


#8

Hi Daniel

I already tried that. Just did it again any Hype still doesn’t open. As I mentioned in the comment above, opening the file logged in as another user works ok.

cheers
Jerome


#9

Can you send a bug report from Hype and reference this thread? I’m not seeing a bug report from you yet — getting your logs would be especially helpful.

This sounds like the Hype file (or perhaps something in its resources) is causing issues. Can you share that as well?


#10

I did send a bug report earlier but now the app crashes before I can send one. Here’s a link to the Hype file https://www.dropbox.com/sh/zegfskcwhvakppd/AABHx6AtdNMPEHECvEm9snd9a?dl=0


#11

Hi Daniel, could you open the attached file? It’s a bit of a pain to have to login to my laptop as a temp user to export the couple of websites I’m working on. If there’s no easy fix let me know and I’ll continue down this route.

Here’s a dropbox link with all associated files https://www.dropbox.com/s/4i8vgdjk39vyghf/home-test.zip?dl=0


#12

It says that the file is uploading – let me know when it is done?


#13

####Just downloaded file and duplicated it - no crash

Version of Hype: 3.5.3 (538)
OS: 10.11.6

####Same procedure and no crash again

Version of Hype 3.5.4 (540)
OS: 10.11.6

I noticed in your video that you may have had Hype running in a different desktop or monitor or window? I couldn’t really tell what was happening. Could this be a potential problem?

Here is my saved duplicate. See if this does the same thing.

BlueFinch-Website-Final-vDBear.hype.zip (2.8 MB)

I’m just wondering that as you’ve re-installed then perhaps there is a corrupt plist file (or other file) somewhere that is causing an issue. I’m not up to date on what files Hype creates when it is installed. Just a thought. If you have “Clean My Mac” or something to remove the app and then re-install perhaps this might help.


#14

I had the same issue on a laptop with a single screen. The file opened ok, duplicating it caused the same instant crash on startup.

Your duplicate or any file still cause the same issue but will open fine for another user. It is definitely something tied to the Hype startup process when it tries to open the previously used file automatically (a feature I wish could be switched off).

I thought about preferences but can’t find them in the usual places. I may give Clean My Mac a try.

cheers
Jerome


#15

The file is uploaded now.


#17

Can you list the steps you took to duplicate the file? Was it from within Hype (File > Duplicate) ?


#18

The initial issue was Hype crashing when I was navigating to a scene. The scene page would go white and Hype would crash.

When I duplicated I used File > Duplicate.


#19

This, I feel is a similar issue. Maybe if you follow the steps outlined here it could help with narrowing the problem.


(Jonathan Deutsch) #20

Actually it is a different case, and I believe I have a fix. I DM’d @jeromeiveson to give it a try and see if it resolves it.